add global make download target
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Jun 2006 23:57:10 +0000 (23:57 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Jun 2006 23:57:10 +0000 (23:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4031 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index 92a49bf..faeecaa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -86,9 +86,16 @@ target/%: .pkginfo FORCE
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world: ./scripts/config/conf FORCE
-       touch .config
+.config: ./scripts/config/conf FORCE
+       @[ -f .config ] || $(MAKE) menuconfig
        $< -D .config Config.in >/dev/null 2>/dev/null
+
+download: .config FORCE
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile