add e2fsprogs package
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Aug 2005 02:46:43 +0000 (02:46 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Aug 2005 02:46:43 +0000 (02:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1652 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/e2fsprogs/Config.in [new file with mode: 0644]
openwrt/package/e2fsprogs/Makefile [new file with mode: 0644]
openwrt/package/e2fsprogs/ipkg/e2fsprogs.control [new file with mode: 0644]

index 8493012..5482c23 100644 (file)
@@ -160,6 +160,7 @@ source "package/strace/Config.in"
 # what are we going to do with both of you
 comment "FileSystems related ---"
 source "package/dosfstools/Config.in"
+source "package/e2fsprogs/Config.in"
 source "package/fuse/Config.in"
 source "package/shfs/Config.in"
 
index 7ee1512..def03c4 100644 (file)
@@ -26,6 +26,7 @@ package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
 package-$(BR2_PACKAGE_DOSFSTOOLS) += dosfstools
 package-$(BR2_PACKAGE_DROPBEAR) += dropbear
 package-$(BR2_PACKAGE_DSNIFF) += dsniff
+package-$(BR2_PACKAGE_E2FSPROGS) += e2fsprogs
 package-$(BR2_PACKAGE_EBTABLES) += ebtables
 package-$(BR2_PACKAGE_ETHER_WAKE) += ether-wake
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
diff --git a/openwrt/package/e2fsprogs/Config.in b/openwrt/package/e2fsprogs/Config.in
new file mode 100644 (file)
index 0000000..658ed33
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_E2FSPROGS
+       tristate "e2fsprogs - Ext2/3 filesystem utilities"
+#      default m if DEVELOPER
+       default n
+       help
+         This package contains essential ext2 filesystem utilities which consists of 
+         e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2 
+         filesystem utilities.
+         
+         http://e2fsprogs.sourceforge.net/
+         
diff --git a/openwrt/package/e2fsprogs/Makefile b/openwrt/package/e2fsprogs/Makefile
new file mode 100644 (file)
index 0000000..1fcd3cb
--- /dev/null
@@ -0,0 +1,79 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=e2fsprogs
+PKG_VERSION:=1.38
+PKG_RELEASE:=1
+PKG_MD5SUM:=d774d4412bfb80d12cf3a4fdfd59de5a
+
+PKG_SOURCE_URL:=@SF/e2fsprogs
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,E2FSPROGS,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.#cache,status}; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --enable-elf-shlibs \
+                       --enable-dynamic-e2fsck \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR)/util \
+               BUILDCC="$(HOSTCC)" \
+               CFLAGS="" \
+               subst
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               BUILDCC="$(HOSTCC)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+       touch $@
+
+$(IPKG_E2FSPROGS):
+       mkdir -p $(IDIR_E2FSPROGS)/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/e2fsck $(IDIR_E2FSPROGS)/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/mke2fs $(IDIR_E2FSPROGS)/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/mkfs.ext{2,3} $(IDIR_E2FSPROGS)/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/tune2fs $(IDIR_E2FSPROGS)/sbin/
+       mkdir -p $(IDIR_E2FSPROGS)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{blkid,com_err,e2p,ext2fs,uuid}.so.* $(IDIR_E2FSPROGS)/usr/lib/
+       $(RSTRIP) $(IDIR_E2FSPROGS)
+       $(IPKG_BUILD) $(IDIR_E2FSPROGS) $(PACKAGE_DIR)
diff --git a/openwrt/package/e2fsprogs/ipkg/e2fsprogs.control b/openwrt/package/e2fsprogs/ipkg/e2fsprogs.control
new file mode 100644 (file)
index 0000000..47d9f99
--- /dev/null
@@ -0,0 +1,6 @@
+Package: e2fsprogs
+Priority: optional
+Section: admin
+Maintainer: OpenWrt Developers <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/e2fsprogs/
+Description: Ext2/3 filesystem utilities