add avahi package
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Aug 2005 08:48:12 +0000 (08:48 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Aug 2005 08:48:12 +0000 (08:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1732 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/avahi/Config.in [new file with mode: 0644]
openwrt/package/avahi/Makefile [new file with mode: 0644]
openwrt/package/avahi/ipkg/avahi-daemon.conffiles [new file with mode: 0644]
openwrt/package/avahi/ipkg/avahi-daemon.control [new file with mode: 0644]
openwrt/package/avahi/ipkg/avahi-dnsconfd.control [new file with mode: 0644]
openwrt/package/avahi/ipkg/libavahi.control [new file with mode: 0644]

index 6259d2d..ea547d9 100644 (file)
@@ -36,6 +36,7 @@ source "package/arptables/Config.in"
 source "package/arpwatch/Config.in"
 source "package/asterisk/Config.in"
 source "package/atftp/Config.in"
+source "package/avahi/Config.in"
 source "package/bind/Config.in"
 source "package/bwm/Config.in"
 source "package/chillispot/Config.in"
index 1d271ff..ee5049a 100644 (file)
@@ -9,6 +9,7 @@ package-$(BR2_PACKAGE_ARPTABLES) += arptables
 package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
 package-$(BR2_PACKAGE_ASTERISK) += asterisk
 package-$(BR2_PACKAGE_ATFP) += atftp
+package-$(BR2_COMPILE_AVAHI) += avahi
 package-$(BR2_PACKAGE_BIND) += bind
 package-$(BR2_PACKAGE_BLUEZ_LIBS) += bluez-libs
 package-$(BR2_PACKAGE_BLUEZ_UTILS) += bluez-utils
@@ -177,6 +178,7 @@ $(INSTALL_PACKAGES): base-files-install
 
 amwall-compile: libamsel-compile
 arpwatch-compile: libpcap-compile
+avahi-compile: libdaemon-compile expat-compile
 bind-compile: openssl-compile
 cyrus-sasl-compile: openssl-compile
 dropbear-compile: zlib-compile
diff --git a/openwrt/package/avahi/Config.in b/openwrt/package/avahi/Config.in
new file mode 100644 (file)
index 0000000..69b6775
--- /dev/null
@@ -0,0 +1,67 @@
+menu "avahi - An mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation"
+
+config BR2_COMPILE_AVAHI
+       bool
+       default n
+       depends BR2_PACKAGE_AVAHI_DAEMON || BR2_PACKAGE_AVAHI_DNSCONFD || BR2_PACKAGE_LIBAVAHI
+
+config BR2_PACKAGE_AVAHI_DAEMON
+       tristate "avahi-daemon - an mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (daemon)"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_COMPILE_AVAHI
+       select BR2_PACKAGE_LIBAVAHI
+       select BR2_PACKAGE_LIBDAEMON
+       help
+         Avahi is a system which facilitates service discovery on a local network -- 
+         this means that you can plug your laptop or computer into a network and 
+         instantly be able to view other people who you can chat with, find printers 
+         to print to or find files being shared. This kind of technology is already 
+         found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
+         and is very convenient.
+         
+         http://www.freedesktop.org/Software/Avahi
+         
+         This package contains an mDNS/DNS-SD daemon.
+         
+
+config BR2_PACKAGE_AVAHI_DNSCONFD
+       tristate "avahi-dnsconfd - an Unicast DNS server from mDNS/DNS-SD configuration daemon"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_COMPILE_AVAHI
+       depends BR2_PACKAGE_AVAHI_DAEMON
+       help
+         Avahi is a system which facilitates service discovery on a local network -- 
+         this means that you can plug your laptop or computer into a network and 
+         instantly be able to view other people who you can chat with, find printers 
+         to print to or find files being shared. This kind of technology is already 
+         found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
+         and is very convenient.
+         
+         http://www.freedesktop.org/Software/Avahi
+         
+         This package contains an Unicast DNS server from mDNS/DNS-SD configuration 
+         daemon, which may be used to configure conventional DNS servers using mDNS 
+         in a DHCP-like fashion. Especially useful on IPv6.
+         
+
+config BR2_PACKAGE_LIBAVAHI
+       tristate "libavahi - an DNS-SD over mDNS (aka RendezVous/Bonjour/ZeroConf) implementation (library)"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_COMPILE_AVAHI
+       help
+         Avahi is a system which facilitates service discovery on a local network -- 
+         this means that you can plug your laptop or computer into a network and 
+         instantly be able to view other people who you can chat with, find printers 
+         to print to or find files being shared. This kind of technology is already 
+         found in MacOS X (branded 'Rendezvous', 'Bonjour' and sometimes 'ZeroConf') 
+         and is very convenient.
+         
+         http://www.freedesktop.org/Software/Avahi
+         
+         This package contains the mDNS/DNS-SD shared libraries, used by other programs.
+         
+
+endmenu
diff --git a/openwrt/package/avahi/Makefile b/openwrt/package/avahi/Makefile
new file mode 100644 (file)
index 0000000..a6b4a62
--- /dev/null
@@ -0,0 +1,137 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=avahi
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=1ccbbc46d2aedf0c864b94c58ea220e6
+
+PKG_SOURCE_URL:=http://www.freedesktop.org/~lennart/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,AVAHI_DAEMON,avahi-daemon,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,AVAHI_DNSCONFD,avahi-dnsconfd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIBAVAHI,libavahi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_realloc_0_nonnull=yes \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --disable-glib \
+                       --disable-gtk \
+                       --disable-dbus \
+                       --enable-expat \
+                       --enable-libdaemon \
+                       --disable-python \
+                       --disable-doxygen-doc \
+                       --disable-doxygen-dot \
+                       --disable-doxygen-html \
+                       --disable-doxygen-ps \
+                       --disable-doxygen-pdf \
+                       --disable-xmltoman \
+                       --with-distro=openwrt \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_AVAHI_DAEMON):
+       install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/avahi
+       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/avahi-daemon.conf $(IDIR_AVAHI_DAEMON)/etc/avahi/
+       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/services $(IDIR_AVAHI_DAEMON)/etc/avahi/
+       install -d -m0755 $(IDIR_AVAHI_DAEMON)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(IDIR_AVAHI_DAEMON)/usr/sbin/
+       $(RSTRIP) $(IDIR_AVAHI_DAEMON)
+       $(IPKG_BUILD) $(IDIR_AVAHI_DAEMON) $(PACKAGE_DIR)
+
+$(IPKG_AVAHI_DNSCONFD):
+       install -d -m0755 $(IDIR_AVAHI_DNSCONFD)/etc/avahi
+       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/avahi-dnsconfd.action $(IDIR_AVAHI_DNSCONFD)/etc/avahi/
+       install -d -m0755 $(IDIR_AVAHI_DNSCONFD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(IDIR_AVAHI_DNSCONFD)/usr/sbin/
+       $(RSTRIP) $(IDIR_AVAHI_DNSCONFD)
+       $(IPKG_BUILD) $(IDIR_AVAHI_DNSCONFD) $(PACKAGE_DIR)
+
+$(IPKG_LIBAVAHI):
+       install -d -m0755 $(IDIR_LIBAVAHI)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.so.* $(IDIR_LIBAVAHI)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.so.* $(IDIR_LIBAVAHI)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBAVAHI)
+       $(IPKG_BUILD) $(IDIR_LIBAVAHI) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/avahi.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/avahi-common $(STAGING_DIR)/usr/include/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/avahi-core $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.a $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.so* $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.a $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.so* $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
+       $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/avahi.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/include/avahi-common \
+               $(STAGING_DIR)/usr/include/avahi-core \
+               $(STAGING_DIR)/usr/lib/libavahi-common.a \
+               $(STAGING_DIR)/usr/lib/libavahi-common.so* \
+               $(STAGING_DIR)/usr/lib/libavahi-core.a \
+               $(STAGING_DIR)/usr/lib/libavahi-core.so* \
+               $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc \
+
+compile: install-dev
+clean: uninstall-dev
+
+mostlyclean:
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
+
diff --git a/openwrt/package/avahi/ipkg/avahi-daemon.conffiles b/openwrt/package/avahi/ipkg/avahi-daemon.conffiles
new file mode 100644 (file)
index 0000000..7f32af6
--- /dev/null
@@ -0,0 +1 @@
+/etc/avahi/avahi-daemon.conf
diff --git a/openwrt/package/avahi/ipkg/avahi-daemon.control b/openwrt/package/avahi/ipkg/avahi-daemon.control
new file mode 100644 (file)
index 0000000..47410fb
--- /dev/null
@@ -0,0 +1,7 @@
+Package: avahi-daemon
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/avahi/
+Depends: libavahi, libdaemon, libexpat
+Description: an mDNS/DNS-SD (aka RendezVous/Bonjour/ZeroConf) implementation (daemon)
diff --git a/openwrt/package/avahi/ipkg/avahi-dnsconfd.control b/openwrt/package/avahi/ipkg/avahi-dnsconfd.control
new file mode 100644 (file)
index 0000000..684a9c4
--- /dev/null
@@ -0,0 +1,7 @@
+Package: avahi-dnsconfd
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/avahi/
+Depends: libavahi, libdaemon, avahi-daemon
+Description: an Unicast DNS server from mDNS/DNS-SD configuration daemon
diff --git a/openwrt/package/avahi/ipkg/libavahi.control b/openwrt/package/avahi/ipkg/libavahi.control
new file mode 100644 (file)
index 0000000..68c6daf
--- /dev/null
@@ -0,0 +1,6 @@
+Package: libavahi
+Priority: optional
+Section: libs
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/avahi/
+Description: an DNS-SD over mDNS (aka RendezVous/Bonjour/ZeroConf) implementation (library)