update pptp in head to whiterussian version
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jul 2005 14:05:46 +0000 (14:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jul 2005 14:05:46 +0000 (14:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1464 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/pptp/Makefile
openwrt/package/pptp/files/ifup.pptp [new file with mode: 0644]
openwrt/package/pptp/files/options.pptp
openwrt/package/pptp/files/pptp.init [deleted file]

index 6c9f515..94ac61c 100644 (file)
@@ -28,8 +28,8 @@ $(PKG_BUILD_DIR)/.built:
        touch $@
 
 $(IPKG_PPTP):
-       install -d -m0755 $(IDIR_PPTP)/etc/init.d
-       install -m0755 ./files/pptp.init $(IDIR_PPTP)/etc/init.d/S50pptp
+       install -d -m0755 $(IDIR_PPTP)/sbin
+       install -m0755 ./files/ifup.pptp $(IDIR_PPTP)/sbin/ifup.pptp
        install -d -m0755 $(IDIR_PPTP)/etc/ppp
        install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
        install -d -m0755 $(IDIR_PPTP)/usr/sbin
diff --git a/openwrt/package/pptp/files/ifup.pptp b/openwrt/package/pptp/files/ifup.pptp
new file mode 100644 (file)
index 0000000..21a574a
--- /dev/null
@@ -0,0 +1,43 @@
+#!/bin/sh
+. /etc/functions.sh
+type=$1
+
+[ "$(nvram get ${type}_proto)" = "pptp" ] || exit
+
+[ -d "/var/lock" ] || mkdir -p /var/lock || exit 1
+
+for module in slhc ppp_generic ppp_async ip_gre; do
+       /sbin/insmod $module 2>&- >&-
+done
+
+if=$(nvram get pptp_ifname)
+ip=$(nvram get ${type}_ipaddr)
+netmask=$(nvram get ${type}_netmask)
+[ -z "$ip" -o -z "$if" ] || ifconfig $if $ip ${netmask:+netmask $netmask} broadcast + up
+
+while :; do
+       IP=$(nvram get pptp_server_ip)
+       USERNAME=$(nvram get ppp_username)
+       PASSWORD=$(nvram get ppp_passwd)
+       REDIAL=$(nvram get ppp_redialperiod)
+       REDIAL=${REDIAL:+lcp-echo-interval $REDIAL}
+       IDLETIME=$(nvram get ppp_idletime)
+       IDLETIME=${IDLETIME:+lcp-echo-failure $IDLETIME}
+       MTU=$(nvram get ppp_mtu)
+       MTU=${MTU:+ mtu $MTU mru $MTU}
+
+       /usr/sbin/pppd nodetach \
+               pty "/usr/sbin/pptp $IP --loglevel 0 --nolaunchpppd" \
+               file /etc/ppp/options.pptp \
+               connect /bin/true \
+               usepeerdns \
+               defaultroute \
+               linkname $type \
+               user "$USERNAME" \
+               password "$PASSWORD" \
+               $MTU \
+               $IDLETIME \
+               $REDIAL \
+               $IFNAME
+done &
+
index 0eb1e87..c520de7 100644 (file)
@@ -2,11 +2,5 @@ lock
 noauth 
 nobsdcomp 
 nodeflate
-mtu 1490
-mru 1490
-lcp-echo-failure 5
-lcp-echo-interval 120
 idle 0
 defaultroute
-name xxxx
-remotename xxxx
diff --git a/openwrt/package/pptp/files/pptp.init b/openwrt/package/pptp/files/pptp.init
deleted file mode 100644 (file)
index 34ff8a6..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-. /etc/functions.sh
-
-WAN_PROTO=$(nvram get wan_proto)
-[ "$WAN_PROTO" = "pptp" ] || exit 0
-
-for module in ip_gre slhc ppp_generic ppp_async ppp_deflate ; do
-   /sbin/insmod $module 2>/dev/null >/dev/null
-done
-               
-if test -d "/var/lock"; then
-  mkdir -p /var/lock || exit 1
-fi
-
-/usr/sbin/pppd pty "pptp x.x.x.x --loglevel 0 --nolaunchpppd" file /etc/ppp/options.pptp
-                   
-