only build bin packages for the selected build variants (same behaviour as with ipkg...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 May 2010 15:57:00 +0000 (15:57 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 May 2010 15:57:00 +0000 (15:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21455 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-bin.mk

index 6ee7aed..96c1aef 100644 (file)
@@ -7,6 +7,7 @@
 
 ifeq ($(DUMP),)
   define BuildTarget/bin
+    ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
     ifdef Package/$(1)/install
       ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
         compile: install-bin-$(1)
@@ -16,6 +17,7 @@ ifeq ($(DUMP),)
                @echo "WARNING: skipping $(1) -- package not selected"
       endif
     endif
+    endif
 
     install-bin-$(1): $(STAMP_BUILT)
          rm -rf $(BIN_DIR)/$(1)