gre: Change hostdependcy to remote endpoint tunnel address
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2014 09:57:55 +0000 (09:57 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2014 09:57:55 +0000 (09:57 +0000)
Depend on the GRE tunnel peeraddr to trigger setup of the tunnel interface.
Addresses the issue reported in https://lists.openwrt.org/pipermail/openwrt-devel/2014-August/027201.html

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41998 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index efca464..9f5135e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index 38c0fc4..1728b01 100755 (executable)
@@ -51,7 +51,7 @@ gre_setup() {
                exit
        }
 
-       ( proto_add_host_dependency "$cfg" "0.0.0.0" "$tunlink" )
+       ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"
@@ -108,7 +108,7 @@ grev6_setup() {
                exit
        }
 
-       ( proto_add_host_dependency "$cfg" "::" "$tunlink" )
+       ( proto_add_host_dependency "$cfg" "$peer6addr" "$tunlink" )
 
        [ -z "$ip6addr" ] && {
                local wanif="$tunlink"