base-files: calling stop_service before procd_kill.
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:42:44 +0000 (12:42 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:42:44 +0000 (12:42 +0000)
Before this patch, doing `/e/c/network restart' will emit the folloing
error by `ubus network.wireless down "{}"' because netifd already quit
by that time.

Command failed: not found

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40906 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/rc.common

index 207af35..eea9ecb 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=152
+PKG_RELEASE:=153
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 829ec76..8701312 100755 (executable)
@@ -112,8 +112,8 @@ ${INIT_TRACE:+set -x}
        }
 
        stop() {
-               procd_kill "$(basename ${basescript:-$initscript})" "$1"
                stop_service "$@"
+               procd_kill "$(basename ${basescript:-$initscript})" "$1"
        }
 
        reload() {