mtd-utils: do not try to compile in support for ubifs ioctls and extended flags ...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Feb 2010 23:02:38 +0000 (23:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Feb 2010 23:02:38 +0000 (23:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19846 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/mtd-utils/Makefile
tools/mtd-utils/patches/110-portability.patch

index 45a61ab..45bceaf 100644 (file)
@@ -21,7 +21,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
-CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib
+CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib -DNO_NATIVE_SUPPORT
 ifneq ($(HOST_OS),Linux)
 CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h -I$(CURDIR)/include -include fls.h
 endif
index 3d0037c..d35b446 100644 (file)
@@ -92,7 +92,7 @@
  
        if (c->default_compr != UBIFS_COMPR_NONE)
                use_flags |= UBIFS_COMPR_FL;
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
        if (flags & FS_COMPR_FL)
                use_flags |= UBIFS_COMPR_FL;
        if (flags & FS_SYNC_FL)
                fd = dirfd(dir);
                if (fd == -1)
                        return sys_err_msg("dirfd failed");
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
                if (ioctl(fd, FS_IOC_GETFLAGS, &flags) == -1)
 +#endif
                        flags = 0;
                key_write(&key, &dn->key);
                dn->size = cpu_to_le32(bytes_read);
                out_len = NODE_BUFFER_SIZE - UBIFS_DATA_NODE_SZ;
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
                if (c->default_compr == UBIFS_COMPR_NONE &&
                    (flags & FS_COMPR_FL))
                        use_compr = UBIFS_COMPR_LZO;
                if (fd == -1)
                        return sys_err_msg("failed to open file '%s'",
                                           path_name);
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
                if (ioctl(fd, FS_IOC_GETFLAGS, &flags) == -1)
 +#endif
                        flags = 0;