Add kmod-ppp-synctty (#2231)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2007 08:31:49 +0000 (08:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2007 08:31:49 +0000 (08:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8459 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/network.mk
target/linux/generic-2.4/config-template

index a7b93e1..6da38e4 100644 (file)
@@ -189,6 +189,19 @@ endef
 $(eval $(call KernelPackage,ppp))
 
 
+define KernelPackage/ppp-synctty
+  TITLE:=PPP sync tty support
+  DESCRIPTION:=\
+       Kernel modules for PPP sync tty support
+  DEPENDS:=kmod-ppp
+  KCONFIG:=CONFIG_PPP_SYNC_TTY
+  SUBMENU:=$(NSMENU)
+  FILES:=$(LINUX_DIR)/drivers/net/ppp_synctty.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,ppp_synctty)
+endef
+$(eval $(call KernelPackage,ppp-synctty))
+
+
 define KernelPackage/pppoe
   TITLE:=PPPoE support
   DESCRIPTION:=\
index 1607f04..9f33ef4 100644 (file)
@@ -579,7 +579,7 @@ CONFIG_PPP_DEFLATE=m
 CONFIG_PPP_FILTER=y
 CONFIG_PPP_MPPE_MPPC=m
 # CONFIG_PPP_MULTILINK is not set
-# CONFIG_PPP_SYNC_TTY is not set
+CONFIG_PPP_SYNC_TTY=m
 # CONFIG_PRISM54 is not set
 CONFIG_PROC_FS=y
 # CONFIG_QFMT_V2 is not set