ramips: add profile for Dlink DIR-615 H1
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Apr 2013 19:03:09 +0000 (19:03 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Apr 2013 19:03:09 +0000 (19:03 +0000)
Hello,
this adds the profile for Dlink DIR-615 H1 without the usb default packages
since this router does not have a usb port and while all the needed definitions
for building are already in target/linux/ramips/image/Makefile this also allows
users to select the exact target in RT305x based boards menuconfig for this router
and compile its firmware.

Signed-off-by: Daniel Petre <dani@ip6.ro>
Patchwork: http://patchwork.openwrt.org/patch/3529/
Acked-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36437 3c298f89-4303-0410-b956-a3cf2f4a3e73

linux/ramips/rt305x/profiles/dlink.mk [new file with mode: 0644]

diff --git a/linux/ramips/rt305x/profiles/dlink.mk b/linux/ramips/rt305x/profiles/dlink.mk
new file mode 100644 (file)
index 0000000..29d8b7c
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DIR615H1
+       NAME:=Dlink DIR-615 H1
+        PACKAGES:=\
+                -kmod-usb-core -kmod-usb-rt305x-dwc_otg \
+                -kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR615H1/Description
+       Package set for Dlink DIR-615 H1 board
+endef
+
+$(eval $(call Profile,DIR615H1))
+