[package] kmod-sctp: Add SCTP kernel support
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Sep 2010 18:06:49 +0000 (18:06 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Sep 2010 18:06:49 +0000 (18:06 +0000)
This adds a new kmod-sctp option that enables support of SCTP in 2.6x
kernels.
The patch also contains a small cleanup in the dependencies.

Signed-off-by: Sebastien Decugis <sdecugis@nict.go.jp>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22917 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/fs.mk
package/kernel/modules/netsupport.mk
package/kernel/modules/other.mk

index 71b1a59..e5714aa 100644 (file)
@@ -25,16 +25,13 @@ $(eval $(call KernelPackage,fs-autofs4))
 define KernelPackage/fs-btrfs
   SUBMENU:=$(FS_MENU)
   TITLE:=BTRFS filesystem support
-  # for crc32c
-  DEPENDS:=+kmod-crypto-core +kmod-crypto-misc
+  DEPENDS:=+kmod-libcrc32c
   KCONFIG:=\
-       CONFIG_LIBCRC32C \
        CONFIG_BTRFS_FS \
        CONFIG_BTRFS_FS_POSIX_ACL=n
   FILES:=\
-       $(LINUX_DIR)/lib/libcrc32c.ko \
        $(LINUX_DIR)/fs/btrfs/btrfs.ko
-  AUTOLOAD:=$(call AutoLoad,30,crc32c libcrc32c btrfs,1)
+  AUTOLOAD:=$(call AutoLoad,30,btrfs,1)
 endef
 
 define KernelPackage/fs-btrfs/description
index 196e5a3..703cc64 100644 (file)
@@ -674,3 +674,25 @@ endef
 $(eval $(call KernelPackage,l2tp-ip))
 
 
+define KernelPackage/sctp
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=SCTP protocol kernel support
+  KCONFIG:=\
+     CONFIG_IP_SCTP \
+     CONFIG_SCTP_DBG_MSG=n \
+     CONFIG_SCTP_DBG_OBJCNT=n \
+     CONFIG_SCTP_HMAC_NONE=n \
+     CONFIG_SCTP_HMAC_SHA1=n \
+     CONFIG_SCTP_HMAC_MD5=y
+  FILES:= $(LINUX_DIR)/net/sctp/sctp.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:= $(call AutoLoad,32,sctp)
+  DEPENDS:=+kmod-libcrc32c +kmod-crypto-md5 +kmod-crypto-hmac
+endef
+
+define KernelPackage/sctp/description
+ Kernel modules for SCTP protocol support
+endef
+
+$(eval $(call KernelPackage,sctp))
+
+
index 18cd79f..53080f8 100644 (file)
@@ -132,6 +132,22 @@ endef
 $(eval $(call KernelPackage,crc16))
 
 
+define KernelPackage/libcrc32c
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=CRC32 library support
+  KCONFIG:=CONFIG_LIBCRC32C
+  DEPENDS:=+kmod-crypto-core +kmod-crypto-misc 
+  FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
+  AUTOLOAD:=$(call AutoLoad,20,crc32c libcrc32c,1)
+endef
+
+define KernelPackage/libcrc32c/description
+ Kernel module for CRC32 support
+endef
+
+$(eval $(call KernelPackage,libcrc32c))
+
+
 define KernelPackage/eeprom-93cx6
   SUBMENU:=$(OTHER_MENU)
   TITLE:=EEPROM 93CX6 support