dropbear: update to 2014.65
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Aug 2014 13:02:43 +0000 (13:02 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Aug 2014 13:02:43 +0000 (13:02 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42131 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/dropbear/Makefile
package/network/services/dropbear/patches/110-change_user.patch
package/network/services/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
package/network/services/dropbear/patches/140-disable_assert.patch
package/network/services/dropbear/patches/500-set-default-path.patch

index b2bd8cc..f793e9b 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=2014.63
+PKG_VERSION:=2014.65
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://matt.ucc.asn.au/dropbear/releases/ \
        https://dropbear.nl/mirror/releases/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://matt.ucc.asn.au/dropbear/releases/ \
        https://dropbear.nl/mirror/releases/
-PKG_MD5SUM:=7066bb9a2da708f3ed06314fdc9c47fd
+PKG_MD5SUM:=1918604238817385a156840fa2c39490
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
index 48228ea..44bfe14 100644 (file)
@@ -1,6 +1,6 @@
 --- a/svr-chansession.c
 +++ b/svr-chansession.c
 --- a/svr-chansession.c
 +++ b/svr-chansession.c
-@@ -889,12 +889,12 @@ static void execchild(void *user_data) {
+@@ -902,12 +902,12 @@ static void execchild(void *user_data) {
        /* We can only change uid/gid as root ... */
        if (getuid() == 0) {
  
        /* We can only change uid/gid as root ... */
        if (getuid() == 0) {
  
index 6de652b..0a5e8ba 100644 (file)
@@ -1,6 +1,6 @@
 --- a/cli-runopts.c
 +++ b/cli-runopts.c
 --- a/cli-runopts.c
 +++ b/cli-runopts.c
-@@ -309,6 +309,10 @@ void cli_getopts(int argc, char ** argv)
+@@ -312,6 +312,10 @@ void cli_getopts(int argc, char ** argv)
                                        debug_trace = 1;
                                        break;
  #endif
                                        debug_trace = 1;
                                        break;
  #endif
                                case 'F':
                                case 'e':
  #ifndef ENABLE_USER_ALGO_LIST
                                case 'F':
                                case 'e':
  #ifndef ENABLE_USER_ALGO_LIST
-@@ -322,7 +326,6 @@ void cli_getopts(int argc, char ** argv)
- #ifndef ENABLE_CLI_LOCALTCPFWD
-                               case 'L':
- #endif
+@@ -329,7 +333,6 @@ void cli_getopts(int argc, char ** argv)
+                                       print_version();
+                                       exit(EXIT_SUCCESS);
+                                       break;
 -                              case 'o':
                                case 'b':
                                        next = &dummy;
 -                              case 'o':
                                case 'b':
                                        next = &dummy;
index edc7547..0717228 100644 (file)
@@ -1,6 +1,6 @@
 --- a/dbutil.h
 +++ b/dbutil.h
 --- a/dbutil.h
 +++ b/dbutil.h
-@@ -92,7 +92,11 @@ int m_str_to_uint(const char* str, unsig
+@@ -101,7 +101,11 @@ int m_str_to_uint(const char* str, unsig
  #define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
  
  /* Dropbear assertion */
  #define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
  
  /* Dropbear assertion */
index 4eea57d..f4cbdee 100644 (file)
@@ -1,6 +1,6 @@
 --- a/options.h
 +++ b/options.h
 --- a/options.h
 +++ b/options.h
-@@ -318,7 +318,7 @@ be overridden at runtime with -I. 0 disa
+@@ -323,7 +323,7 @@ be overridden at runtime with -I. 0 disa
  #define DEFAULT_IDLE_TIMEOUT 0
  
  /* The default path. This will often get replaced by the shell */
  #define DEFAULT_IDLE_TIMEOUT 0
  
  /* The default path. This will often get replaced by the shell */