[package/hotplug2] link against 'libbsd' when using glibc
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jun 2011 22:51:20 +0000 (22:51 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jun 2011 22:51:20 +0000 (22:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27209 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hotplug2/Makefile

index 9625ba2..699976e 100644 (file)
@@ -28,7 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
-  DEPENDS:=+USE_EGLIBC:libbsd
+  DEPENDS:=+USE_EGLIBC:libbsd +USE_GLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
   TARGET_LDFLAGS += -lbsd
 endif