package: use file_copy to deploy files/ in the package/install phase
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 Dec 2012 12:20:38 +0000 (12:20 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 Dec 2012 12:20:38 +0000 (12:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34438 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index eab3f85..e88efdf 100644 (file)
@@ -89,15 +89,7 @@ $(curdir)/install: $(TMP_DIR)/.build
        done || true
        @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
        done || true
        @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
-               ( cd $(TOPDIR)/files; find -type f ) | \
-                       ( cd $(TARGET_DIR); while :; do \
-                               read FILE; \
-                               [ -z "$$FILE" ] && break; \
-                               [ -L "$$FILE" ] || continue; \
-                               echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
-                               rm -f "$$FILE"; \
-                       done; ); \
-               $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
+               $(call file_copy,$(TOPDIR)/files/.,$(TARGET_DIR)); \
        fi
        @mkdir -p $(TARGET_DIR)/etc/rc.d
        @( \
        fi
        @mkdir -p $(TARGET_DIR)/etc/rc.d
        @( \