toolchain: stop generating broken symlink in TOOLCHAIN_DIR/lib
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Mar 2013 12:16:39 +0000 (12:16 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Mar 2013 12:16:39 +0000 (12:16 +0000)
It turns out that the symlink may exists already by the time the toolchain
Makefile gets an opportunity to run. While we asked to replace the target, ln
doesn't do so until after dereferencing the existing symlink. This results in
an unintended symlink that refers to itself. Instead, create the link without
dereferencing any symlinks by using the -n option.

Signed-off-by: John Szakmeister <john@szakmeister.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36140 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/Makefile

index bdfb29e..763381a 100644 (file)
@@ -63,7 +63,7 @@ ifneq ($(ARCH),)
                $(if $(QUIET),,set -x;) \
                mkdir -p "$$dir"; \
                cd "$$dir"; \
-               ln -sf lib lib64; \
+               ln -nsf lib lib64; \
                mkdir -p stamp lib usr/include usr/lib ; \
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@