generate md5 checksums of generated firware images. closes #4003
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 7 Oct 2008 08:01:55 +0000 (08:01 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 7 Oct 2008 08:01:55 +0000 (08:01 +0000)
 - checksums located in bin/md5sums
 - integrity can be verified using md5sum -c

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12889 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 6eef6ba..6ac177d 100644 (file)
@@ -78,6 +78,13 @@ else
   endef
 endif
 
+define Image/Checksum
+       ( cd ${BIN_DIR} ; \
+               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
+               md5sum > md5sums \
+       )
+endef
+
 
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
@@ -128,6 +135,7 @@ ifneq ($(IB),1)
        $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
+       $(call Image/Checksum)
 else
   install: compile install-targets
        $(call Image/BuildKernel)
@@ -137,6 +145,7 @@ else
        $(call Image/mkfs/cpiogz)
        $(call Image/mkfs/ext2)
        $(call Image/mkfs/iso)
+       $(call Image/Checksum)
 endif
 
 ifneq ($(IB),1)