sync to kernel 2.6.32.12
authoracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Apr 2010 14:30:08 +0000 (14:30 +0000)
committeracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Apr 2010 14:30:08 +0000 (14:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21195 3c298f89-4303-0410-b956-a3cf2f4a3e73

24 files changed:
include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cobalt/Makefile
target/linux/etrax/Makefile
target/linux/gemini/Makefile
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/malta/Makefile
target/linux/omap35xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/pxa/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/sibyte/Makefile
target/linux/x86/Makefile
target/linux/xburst/Makefile

index 6da056a..fbf934a 100644 (file)
@@ -17,12 +17,6 @@ endif
 ifeq ($(LINUX_VERSION),2.6.31.12)
   LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
 endif
-ifeq ($(LINUX_VERSION),2.6.32.10)
-  LINUX_KERNEL_MD5SUM:=5d996507ad482a3a8c8e6b2d48e7994b
-endif
-ifeq ($(LINUX_VERSION),2.6.32.11)
-  LINUX_KERNEL_MD5SUM:=3709c691d909b4f8ca692edc6c726cb6
-endif
 ifeq ($(LINUX_VERSION),2.6.32.12)
   LINUX_KERNEL_MD5SUM:=bc87db696ed4be729334584493d6d98d
 endif
index 38efd92..97c616b 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 74f4094..9c7e605 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
 FEATURES:=squashfs jffs2 tgz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f9011b2..0c6e8cb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index bfec965..0e2eb55 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f493929..05c38ef 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index d5285ba..a264563 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index d091177..69705e9 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
 FEATURES:=tgz pci ext2
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 875034c..c9e047f 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 0b1d889..a427089 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 32fee6f..20881a4 100644 (file)
@@ -12,8 +12,6 @@ BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 atm
 SUBTARGETS:=danube #ar9
 
-#LINUX_VERSION:=2.6.30.10
-#LINUX_VERSION:=2.6.32.10
 LINUX_VERSION:=2.6.33.2
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
index 8dd2c1b..cdcc420 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6f822e6..452f703 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 48e0cc1..fa565ea 100644 (file)
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 3a13edb..a7354b6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
 FEATURES:=broken
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 KERNELNAME:="uImage"
 
 DEVICE_TYPE=developerboard
index ea7cee3..7d2a7c1 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 905574b..aa8313a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index df67306..aba9f43 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index ba05bef..567ad1f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=pxa
 BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 326ecfb..6a65a5f 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
index 3b2716d..b425383 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index b21860a..4131848 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6b248f6..6662912 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f118b7c..7925c49 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 tgz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.32.12
 
 DEVICE_TYPE=other