upgrade to iptables 1.3.5
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Mar 2006 11:43:35 +0000 (11:43 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Mar 2006 11:43:35 +0000 (11:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3448 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/iptables/Makefile
openwrt/package/iptables/patches/03-gcc4_fix.patch [deleted file]

index 1792fe3..38eb907 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iptables
-PKG_VERSION:=1.3.4
+PKG_VERSION:=1.3.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=fdff8abe890807968226b0c374335305
+PKG_MD5SUM:=00fb916fa8040ca992a5ace56d905ea5
 
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
diff --git a/openwrt/package/iptables/patches/03-gcc4_fix.patch b/openwrt/package/iptables/patches/03-gcc4_fix.patch
deleted file mode 100644 (file)
index 26ef110..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Nur iptables-1.3.4/extensions/libipt_string.c iptables-1.3.4-openwrt/extensions/libipt_string.c
---- iptables-1.3.4/extensions/libipt_string.c  2005-10-31 20:03:50.000000000 +0100
-+++ iptables-1.3.4-openwrt/extensions/libipt_string.c  2005-12-15 15:08:27.000000000 +0100
-@@ -63,7 +63,7 @@
- }
- static void
--parse_string(const unsigned char *s, struct ipt_string_info *info)
-+parse_string(const char *s, struct ipt_string_info *info)
- {     
-       if (strlen(s) <= IPT_STRING_MAX_PATTERN_SIZE) {
-               strncpy(info->pattern, s, IPT_STRING_MAX_PATTERN_SIZE);
-@@ -74,7 +74,7 @@
- }
- static void
--parse_algo(const unsigned char *s, struct ipt_string_info *info)
-+parse_algo(const char *s, struct ipt_string_info *info)
- {
-       if (strlen(s) <= IPT_STRING_MAX_ALGO_NAME_SIZE) {
-               strncpy(info->algo, s, IPT_STRING_MAX_ALGO_NAME_SIZE);
-@@ -84,7 +84,7 @@
- }
- static void
--parse_hex_string(const unsigned char *s, struct ipt_string_info *info)
-+parse_hex_string(const char *s, struct ipt_string_info *info)
- {
-       int i=0, slen, sindex=0, schar;
-       short hex_f = 0, literal_f = 0;