dnsmasq: use COPTS for compile time options
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jun 2014 10:04:02 +0000 (10:04 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jun 2014 10:04:02 +0000 (10:04 +0000)
As documented in config.h.
Doing otherwise will break dnsmasq's pkg-wrapper script to find its
libs to link to.

Signed-off-by: Andre Heider <a.heider@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41241 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/dnsmasq/Makefile

index 8e2d41c..c0d3dc4 100644 (file)
@@ -61,18 +61,19 @@ endef
 
 Package/dnsmasq-dhcpv6/conffiles = $(Package/dnsmasq/conffiles)
 
-TARGET_CFLAGS += \
-       -ffunction-sections -fdata-sections \
-       $(if $(CONFIG_IPV6),,-DNO_IPV6) -DNO_IPSET -DNO_AUTH
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
+COPTS = $(if $(CONFIG_IPV6),,-DNO_IPV6) -DNO_IPSET -DNO_AUTH
 
 ifeq ($(BUILD_VARIANT),nodhcpv6)
-  TARGET_CFLAGS += -DNO_DHCP6
+       COPTS += -DNO_DHCP6
 endif
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(TARGET_CFLAGS)" \
        LDFLAGS="-Wl,--gc-sections" \
+       COPTS="$(COPTS)" \
        PREFIX="/usr"
 
 define Package/dnsmasq/install