brcm47xx: switch to the otrx for verifying TRX images
authorrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Apr 2015 05:22:04 +0000 (05:22 +0000)
committerrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Apr 2015 05:22:04 +0000 (05:22 +0000)
This adds checking CRC32 of provided firmware image.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45316 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/Makefile
target/linux/brcm47xx/base-files/lib/upgrade/platform.sh

index cde8f14..22b8674 100644 (file)
@@ -22,7 +22,7 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with MIPS CPU, *not* ARM.
 endef
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+DEFAULT_PACKAGES += swconfig wpad-mini nvram otrx \
        kmod-leds-gpio kmod-gpio-button-hotplug \
        kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
 
index f5b9bda..b9110a7 100644 (file)
@@ -77,20 +77,6 @@ brcm47xx_identify() {
        echo "unknown"
 }
 
-# $(1): image that should contain trx
-# $(2): trx offset in image
-platform_check_image_trx() {
-       local magic=$(get_magic_long_at "$1" $2)
-
-       [ "$magic" != "48445230" ] && {
-               return 1
-       }
-
-       # TODO: Check crc32
-
-       return 0
-}
-
 platform_check_image() {
        [ "$#" -gt 1 ] && return 1
 
@@ -111,7 +97,7 @@ platform_check_image() {
                                error=1
                        }
 
-                       if ! platform_check_image_trx "$1" "$header_len"; then
+                       if ! otrx -c "$1" -o "$header_len"; then
                                echo "No valid TRX firmware in the CHK image"
                                error=1
                        fi
@@ -126,7 +112,7 @@ platform_check_image() {
                                error=1
                        }
 
-                       if ! platform_check_image_trx "$1" 32; then
+                       if ! otrx -c "$1" -o 32; then
                                echo "No valid TRX firmware in the CyberTAN image"
                                error=1
                        fi