iproute2: bump version from v3.18.0 to v3.19.0
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2015 14:14:39 +0000 (14:14 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2015 14:14:39 +0000 (14:14 +0000)
with refreshed patches

Signed-off-by: Russell Senior <russell@personaltelco.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44479 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/006-no_sctp.patch
package/network/utils/iproute2/patches/120-libnetlink-pic.patch
package/network/utils/iproute2/patches/200-add-tc_esfq.patch
package/network/utils/iproute2/patches/210-add-act_connmark.patch
package/network/utils/iproute2/patches/300-ip_tiny.patch

index ad14ac4..56d2897 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=3.18.0
+PKG_VERSION:=3.19.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=6f6ad51a00007880460e103367b16057
+PKG_MD5SUM:=237083a1e3c388cde7a115a5724dc72a
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0
 
index d4a0de0..a3b2880 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/ipxfrm.c
 +++ b/ip/ipxfrm.c
-@@ -469,7 +469,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -467,7 +467,6 @@ void xfrm_selector_print(struct xfrm_sel
        switch (sel->proto) {
        case IPPROTO_TCP:
        case IPPROTO_UDP:
@@ -8,7 +8,7 @@
        case IPPROTO_DCCP:
        default: /* XXX */
                if (sel->sport_mask)
-@@ -1282,7 +1281,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1336,7 +1335,6 @@ static int xfrm_selector_upspec_parse(st
                switch (sel->proto) {
                case IPPROTO_TCP:
                case IPPROTO_UDP:
index 3ea7d19..26cc569 100644 (file)
@@ -1,10 +1,11 @@
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -1,6 +1,6 @@
- include ../Config
+@@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
+       CFLAGS += -DHAVE_SETNS
+ endif
  
 -CFLAGS += -fPIC
 +CFLAGS += $(FPIC)
  
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o
+ UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o
  
index 19d8199..6c148ea 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -8,6 +8,7 @@ SHARED_LIBS ?= y
+@@ -13,6 +13,7 @@ SHARED_LIBS ?= y
  TCMODULES :=
  TCMODULES += q_fifo.o
  TCMODULES += q_sfq.o
index c0bf07a..10167ae 100644 (file)
@@ -1,13 +1,13 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -39,6 +39,7 @@ TCMODULES += m_mirred.o
+@@ -44,6 +44,7 @@ TCMODULES += m_mirred.o
  TCMODULES += m_nat.o
  TCMODULES += m_pedit.o
  TCMODULES += m_skbedit.o
 +TCMODULES += m_connmark.o
  TCMODULES += m_csum.o
  TCMODULES += m_simple.o
- TCMODULES += p_ip.o
+ TCMODULES += m_vlan.o
 --- /dev/null
 +++ b/tc/m_connmark.c
 @@ -0,0 +1,74 @@
index 3620120..4295d0a 100644 (file)
@@ -25,7 +25,7 @@
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -69,30 +69,42 @@ static const struct cmd {
+@@ -71,30 +71,42 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
@@ -70,7 +70,7 @@
  };
 --- a/lib/utils.c
 +++ b/lib/utils.c
-@@ -629,6 +629,7 @@ const char *rt_addr_n2a(int af, const vo
+@@ -630,6 +630,7 @@ const char *rt_addr_n2a(int af, const vo
        case AF_INET:
        case AF_INET6:
                return inet_ntop(af, addr, buf, buflen);
@@ -78,7 +78,7 @@
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
-@@ -637,6 +638,7 @@ const char *rt_addr_n2a(int af, const vo
+@@ -638,6 +639,7 @@ const char *rt_addr_n2a(int af, const vo
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
@@ -86,7 +86,7 @@
        default:
                return "???";
        }
-@@ -712,6 +714,7 @@ const char *format_host(int af, int len,
+@@ -713,6 +715,7 @@ const char *format_host(int af, int len,
                        case AF_INET6:
                                len = 16;
                                break;
@@ -94,7 +94,7 @@
                        case AF_IPX:
                                len = 10;
                                break;
-@@ -722,6 +725,7 @@ const char *format_host(int af, int len,
+@@ -723,6 +726,7 @@ const char *format_host(int af, int len,
                                len = 2;
                                break;
  #endif
                }
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -1,5 +1,9 @@
- include ../Config
+@@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
+       CFLAGS += -DHAVE_SETNS
+ endif
  
 +ifeq ($(IP_CONFIG_TINY),y)
 +  CFLAGS += -DIPROUTE2_TINY
 +
  CFLAGS += $(FPIC)
  
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o
+ UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o