gcc: gcc 4.9.x disable libsanitize
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 14:59:45 +0000 (14:59 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 14:59:45 +0000 (14:59 +0000)
gcc 4.9.x enables building of libsanitize

- libsanitize needs some headers that are not available
  in uclibc (netrom/netrom.h)

according to buildroot project:
- build fail with musl
- need wordexp with uclibc which increases uclibc size
http://git.buildroot.net/buildroot/commit/?id=5f4d658d888b539de9a6247ae5b1a0999de5d4ec
http://git.buildroot.net/buildroot/commit/?id=554e29e267e6b36a0fd78c82cbad2c82d939eb7f

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42767 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/final/Makefile
toolchain/gcc/minimal/Makefile

index 3529616..3fb5ccf 100644 (file)
@@ -4,6 +4,7 @@ include ../common.mk
 
 GCC_CONFIGURE += \
        --with-headers=$(TOOLCHAIN_DIR)/include \
+       --disable-libsanitizer \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
index a2564a1..0344e1a 100644 (file)
@@ -6,6 +6,7 @@ GCC_CONFIGURE += \
        --with-newlib \
        --without-headers \
        --enable-languages=c \
+       --disable-libsanitizer \
        --disable-libssp \
        --disable-shared \
        --disable-threads