[package] kernel: make kmod-ipt-filter available on brcm-2.4, kernel 2.4 provides...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 May 2009 22:59:07 +0000 (22:59 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 May 2009 22:59:07 +0000 (22:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15549 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netfilter.mk

index 6226c7e..45ae41f 100644 (file)
@@ -78,7 +78,7 @@ define KernelPackage/ipt-filter
   KCONFIG:=$(KCONFIG_IPT_FILTER)
   FILES:=$(foreach mod,$(IPT_FILTER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_FILTER-m)))
-  DEPENDS:= kmod-ipt-core +kmod-textsearch
+  DEPENDS:= kmod-ipt-core @LINUX_2_4||+kmod-textsearch
 endef
 
 define KernelPackage/ipt-filter/description