prereq-build: test availability of Perl Thread::Queue module
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Sep 2015 11:37:10 +0000 (11:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Sep 2015 11:37:10 +0000 (11:37 +0000)
This is needed for building automake.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47069 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index f5fb9e2..6f49137 100644 (file)
@@ -76,6 +76,10 @@ $(eval $(call TestHostCommand,libssl, \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
                gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
 
+$(eval $(call TestHostCommand,perl-thread-queue, \
+       Please install the Perl Thread::Queue module, \
+       perl -MThread::Queue -e 1))
+
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \