add wlc (wl replacement)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Mar 2005 00:00:54 +0000 (00:00 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Mar 2005 00:00:54 +0000 (00:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@373 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/openwrt/Makefile
openwrt/package/openwrt/wlc/Makefile [new file with mode: 0644]
openwrt/package/openwrt/wlc/wlc.c [new file with mode: 0644]

index 0f57daa..2c695bc 100644 (file)
@@ -2,13 +2,13 @@ include $(TOPDIR)/rules.mk
 
 SHARED_INCLUDE:=${shell pwd}/include
 
-libshared-compile libnvram-compile:
+libshared-compile libnvram-compile wlc-compile:
        @$(MAKE) -C $(patsubst %-compile,%,$@) compile
        
-libshared-install libnvram-install:
+libshared-install libnvram-install wlc-install:
        @$(MAKE) -C $(patsubst %-install,%,$@) install
 
-libshared-clean libnvram-clean:
+libshared-clean libnvram-clean wlc-clean:
        @$(MAKE) -C $(patsubst %-clean,%,$@) clean
 
 $(TARGET_DIR)/sbin/mtd: mtd.c
@@ -24,7 +24,6 @@ $(TARGET_DIR)/sbin/jffs2root: jffs2root.c
 LINKSYS_TGZ_SITE=http://openwrt.openbsd-geek.de
 LINKSYS_WLCONF_TGZ=linksys-wlconf.tar.gz
 LINKSYS_WLCONF_DIR=$(BUILD_DIR)/linksys-wlconf
-LINKSYS_WLCONF_TARGET_BINARY:=usr/sbin/wlconf
 
 $(DL_DIR)/$(LINKSYS_WLCONF_TGZ):
        $(WGET) -P $(DL_DIR) $(LINKSYS_TGZ_SITE)/$(LINKSYS_WLCONF_TGZ)
@@ -33,7 +32,7 @@ $(LINKSYS_WLCONF_DIR)/.unpacked: $(DL_DIR)/$(LINKSYS_WLCONF_TGZ)
        zcat $(DL_DIR)/$(LINKSYS_WLCONF_TGZ) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        touch $(LINKSYS_WLCONF_DIR)/.unpacked
        
-$(TARGET_DIR)/$(LINKSYS_WLCONF_TARGET_BINARY): $(LINKSYS_WLCONF_DIR)/.unpacked 
+$(TARGET_DIR)/usr/sbin/wlconf: $(LINKSYS_WLCONF_DIR)/.unpacked 
        $(MAKE) -C $(LINKSYS_WLCONF_DIR) INSTALLDIR=$(TARGET_DIR) \
                CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld STRIP="$(STRIP)" \
                CFLAGS="$(TARGET_CFLAGS) -I. -I$(SHARED_INCLUDE) \
@@ -42,12 +41,13 @@ $(TARGET_DIR)/$(LINKSYS_WLCONF_TARGET_BINARY): $(LINKSYS_WLCONF_DIR)/.unpacked
                        install
        $(STRIP) $@
 
-
 source:
 prepare: 
-compile: libnvram-compile libshared-compile
-install: libnvram-install libshared-install $(TARGET_DIR)/sbin/mtd $(TARGET_DIR)/sbin/jffs2root $(TARGET_DIR)/$(LINKSYS_WLCONF_TARGET_BINARY)
-clean: libnvram-clean libshared-clean
+compile: libnvram-compile libshared-compile wlc-compile
+install: libnvram-install libshared-install wlc-install \
+       $(TARGET_DIR)/sbin/mtd $(TARGET_DIR)/sbin/jffs2root $(TARGET_DIR)/usr/sbin/wlconf
+
+clean: libnvram-clean libshared-clean wlc-clean
        rm -rf $(LINKSYS_WLCONF_DIR)
        rm -f $(TARGET_DIR)/sbin/mtd
        rm -f $(TARGET_DIR)/sbin/jffs2root
diff --git a/openwrt/package/openwrt/wlc/Makefile b/openwrt/package/openwrt/wlc/Makefile
new file mode 100644 (file)
index 0000000..378f187
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Linux router shared code Makefile
+#
+# Copyright 2001-2003, Broadcom Corporation
+# All Rights Reserved.
+# 
+# THIS SOFTWARE IS OFFERED "AS IS", AND BROADCOM GRANTS NO WARRANTIES OF ANY
+# KIND, EXPRESS OR IMPLIED, BY STATUTE, COMMUNICATION OR OTHERWISE. BROADCOM
+# SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS
+# FOR A SPECIFIC PURPOSE OR NONINFRINGEMENT CONCERNING THIS SOFTWARE.
+#
+# $Id$
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wlc
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+EXTRA_CFLAGS := -c -I. -I../include
+
+all: compile
+
+WLC_OBJS:=
+define OBJ_template
+$(PKG_BUILD_DIR)/$(1): $(PKG_BUILD_DIR)
+       $(TARGET_CC) $(TARGET_CFLAGS) $(EXTRA_CFLAGS) -o $$@ $$(patsubst %.o,%.c,$(1))
+WLC_OBJS += $(PKG_BUILD_DIR)/$(1)
+endef
+
+OBJS := wlc.o
+$(foreach obj,$(OBJS),$(eval $(call OBJ_template,$(obj))))
+
+$(PKG_BUILD_DIR):
+       mkdir -p $(PKG_BUILD_DIR)
+
+$(PKG_BUILD_DIR)/wlc: $(WLC_OBJS)
+       $(TARGET_CC) -o $@ $^ -lshared 
+
+$(TARGET_DIR)/usr/sbin/wlc: $(PKG_BUILD_DIR)/wlc
+       install -m 755 $^ $@
+       $(STRIP) $@
+
+compile: $(PKG_BUILD_DIR)/wlc
+install: $(TARGET_DIR)/usr/sbin/wlc
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
diff --git a/openwrt/package/openwrt/wlc/wlc.c b/openwrt/package/openwrt/wlc/wlc.c
new file mode 100644 (file)
index 0000000..464310c
--- /dev/null
@@ -0,0 +1,133 @@
+/*
+ * wl - tool for configuring the Broadcom Wireless Network Adapter
+ * Copyright (C) 2005 Felix Fietkau <nbd@vd-s.ath.cx>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+
+#include <typedefs.h>
+#include <wlutils.h>
+
+struct wl_config {
+       char *name, *desc;
+       enum {
+               INT,
+               BOOL,
+               OTHER
+       } type;
+       int get, set;
+       int r1, r2;
+       char *data;
+};
+
+struct wl_config commands[] = {
+       {"txpwr", "transmit power (in mW)", INT, WLC_GET_TXPWR, WLC_SET_TXPWR, 0, 255, NULL},
+       {"promisc", "promiscuous mode", BOOL, WLC_GET_PROMISC, WLC_SET_PROMISC, 0, 0, NULL},
+       {"monitor", "monitor mode", BOOL, WLC_GET_AP, WLC_SET_AP, 0, 0, NULL},
+       {"ap", "access point mode (0 = STA, 1 = AP)", BOOL, WLC_GET_AP, WLC_SET_AP, 0, 0, NULL},
+       {"infra", "infrastructure mode (0 = IBSS, 1 = Infra BSS)", BOOL, WLC_GET_INFRA, WLC_SET_INFRA, 0, 0, NULL},
+       {"antdiv", "rx antenna diversity (0 = antenna 0, 1 = antenna 1, 3 = auto select)", INT, WLC_GET_ANTDIV, WLC_SET_ANTDIV, 0, 3, NULL},
+       {"txant", "set tx antenna (0 = antenna 0, 1 = antenna 1, 3 = rx antenna)", INT, WLC_GET_TXANT, WLC_SET_TXANT, 0, 3, NULL},
+       {"channel", "set channel", INT, WLC_GET_CHANNEL, WLC_SET_CHANNEL, 1, 14, NULL},
+       {NULL, NULL, 0, 0, 0, 0, 0, NULL}
+};
+
+void set_int(char *name, int ioctl, int value, int r1, int r2)
+{
+       if ((value >= r1) || (value <= r2)) {
+               wl_ioctl(name, ioctl, &value, sizeof(value));
+       } else
+               fprintf(stderr, "invalid value.\n");
+}
+
+void get_int(char *name, int ioctl)
+{
+       int value = 0;
+       wl_ioctl(name, ioctl, &value, sizeof(value));
+       printf("%d\n", value);
+}
+
+int main(int argc, char **argv)
+{
+       struct wl_config *cmd; 
+       int i;
+       
+       if (argc < 3) {
+               fprintf(stderr, "Usage: %s <interface> <command> [...]\n\n", argv[0]);
+               fprintf(stderr, "Commands:\n\n");
+               
+               cmd = commands;
+               while (cmd->name != NULL) {
+                       fprintf(stderr, "\t%s", cmd->name);
+                       switch (cmd->type) {
+                               case INT:
+                                       fprintf(stderr, " [%d-%d]", cmd->r1, cmd->r2);
+                                       break;
+                               case BOOL:
+                                       fprintf(stderr, " [0|1]");
+                                       cmd->r1 = 0;
+                                       cmd->r2 = 1;
+                                       
+                       }
+                       fprintf(stderr, "\t%s\n", cmd->desc);
+                       cmd++;
+               }
+               fprintf(stderr, "\n");
+               
+               return -1;
+       }
+
+       if (wl_probe(argv[1]) < 0) {
+               fprintf(stderr, "No broadcom extensions detected on interface %s\n", argv[1]);
+               return -1;
+       }
+
+       if ((argc > 4) && (strcmp(argv[2], "ioctl") == 0)) {
+               if (strcmp(argv[3], "int") == 0) {
+                       int ioctl = atoi(argv[4]);
+                       if (argc > 5)
+                               i = atoi(argv[5]);
+                       else
+                               i = 0;
+                       fprintf(stderr, "ioctl = 0x%x (%d)\nold value = 0x%x (%d)\n", ioctl, ioctl, i, i);
+                       wl_ioctl(argv[1], ioctl, &i, sizeof(i));
+                       fprintf(stderr, "new value = 0x%x (%d)\n", i, i);
+               }
+               return 0;
+       }
+       cmd = commands;
+       while (cmd->name != NULL) {
+               if (strcmp(argv[2], cmd->name) == 0) {
+                       switch (cmd->type) {
+                               case INT:
+                               case BOOL:
+                                       if (argc < 4) {
+                                               get_int(argv[1], cmd->get);
+                                       } else {
+                                               set_int(argv[1], cmd->set, atoi(argv[3]), cmd->r1, cmd->r2);
+                                       }
+                               break;
+                       }
+               }
+               cmd++;
+       }
+       
+       
+       return 0;
+}