fix build depends for wlc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Apr 2005 10:43:04 +0000 (10:43 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Apr 2005 10:43:04 +0000 (10:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@512 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openwrt/Makefile

index 4c129fd..1580c13 100644 (file)
@@ -10,10 +10,10 @@ PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
 SHARED_INCLUDE:=${shell pwd}/include
 
-libshared-compile libnvram-compile wlc-compile:
+libshared-compile libnvram-compile:
        @$(MAKE) -C $(patsubst %-compile,%,$@) compile
        
-libshared-install libnvram-install wlc-install:
+libshared-install libnvram-install: libshared-compile libnvram-compile
        @$(MAKE) -C $(patsubst %-install,%,$@) install
 
 libshared-clean libnvram-clean wlc-clean:
@@ -27,7 +27,7 @@ $(PKG_IPK_DIR)/sbin/jffs2root: jffs2root.c
        mkdir -p $(PKG_IPK_DIR)/sbin
        $(TARGET_CC) -o $@ $<
 
-$(PKG_IPK_DIR)/usr/sbin/wlc: wlc.c libshared-compile
+$(PKG_IPK_DIR)/usr/sbin/wlc: wlc.c libshared-install
        mkdir -p $(PKG_IPK_DIR)/usr/sbin
        $(TARGET_CC) -o $@ $< -lshared -L./libshared -I$(SHARED_INCLUDE)