Convert pptp to new packaging style
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 May 2005 23:42:09 +0000 (23:42 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 May 2005 23:42:09 +0000 (23:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@941 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/pptp/Config.in
openwrt/package/pptp/Makefile
openwrt/package/pptp/files/options.pptp [new file with mode: 0644]
openwrt/package/pptp/files/pptp.init [new file with mode: 0644]
openwrt/package/pptp/ipkg/etc/init.d/S50pptp [deleted file]
openwrt/package/pptp/ipkg/etc/ppp/options.pptp [deleted file]
openwrt/package/pptp/ipkg/pptp.conffiles [new file with mode: 0644]
openwrt/package/pptp/ipkg/pptp.control [new file with mode: 0644]
openwrt/package/pptp/pptp.control [deleted file]

index 8ffeff2..ad41744 100644 (file)
@@ -1,7 +1,11 @@
 config BR2_PACKAGE_PPTP
-       tristate "PPTP Client"
+       prompt "pptp - a PPTP (Point-to-Point Tunneling Protocol) client"
+       tristate
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_KMOD_GRE
        select BR2_PACKAGE_PPP
        help
          A Point-to-Point Tunneling Protocol Client 
+         
+         http://pptpclient.sourceforge.net/
+         
index a07d6bd..b54b9d3 100644 (file)
@@ -9,42 +9,30 @@ PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 
 PKG_SOURCE_URL:=@SF/pptpclient
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PPTP,pptp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
+$(PKG_BUILD_DIR)/.configured:
+       touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
-        CC=$(TARGET_CC) \
-        CFLAGS="$(TARGET_CFLAGS)" \
-        all
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp -a ./ipkg/* $(PKG_IPK_DIR)/
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       cp $(PKG_BUILD_DIR)/pptp $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/pptp.list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/pptp.list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+               CC=$(TARGET_CC) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_PPTP):
+       install -d -m0755 $(IDIR_PPTP)/etc/init.d
+       install -m0755 ./files/pptp.init $(IDIR_PPTP)/etc/init.d/S50pptp
+       install -d -m0755 $(IDIR_PPTP)/etc/ppp
+       install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
+       install -d -m0755 $(IDIR_PPTP)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/pptp $(IDIR_PPTP)/usr/sbin/
+       $(RSTRIP) $(IDIR_PPTP)
+       $(IPKG_BUILD) $(IDIR_PPTP) $(PACKAGE_DIR)
diff --git a/openwrt/package/pptp/files/options.pptp b/openwrt/package/pptp/files/options.pptp
new file mode 100644 (file)
index 0000000..0eb1e87
--- /dev/null
@@ -0,0 +1,12 @@
+lock 
+noauth 
+nobsdcomp 
+nodeflate
+mtu 1490
+mru 1490
+lcp-echo-failure 5
+lcp-echo-interval 120
+idle 0
+defaultroute
+name xxxx
+remotename xxxx
diff --git a/openwrt/package/pptp/files/pptp.init b/openwrt/package/pptp/files/pptp.init
new file mode 100644 (file)
index 0000000..34ff8a6
--- /dev/null
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+. /etc/functions.sh
+
+WAN_PROTO=$(nvram get wan_proto)
+[ "$WAN_PROTO" = "pptp" ] || exit 0
+
+for module in ip_gre slhc ppp_generic ppp_async ppp_deflate ; do
+   /sbin/insmod $module 2>/dev/null >/dev/null
+done
+               
+if test -d "/var/lock"; then
+  mkdir -p /var/lock || exit 1
+fi
+
+/usr/sbin/pppd pty "pptp x.x.x.x --loglevel 0 --nolaunchpppd" file /etc/ppp/options.pptp
+                   
+
diff --git a/openwrt/package/pptp/ipkg/etc/init.d/S50pptp b/openwrt/package/pptp/ipkg/etc/init.d/S50pptp
deleted file mode 100755 (executable)
index 34ff8a6..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-. /etc/functions.sh
-
-WAN_PROTO=$(nvram get wan_proto)
-[ "$WAN_PROTO" = "pptp" ] || exit 0
-
-for module in ip_gre slhc ppp_generic ppp_async ppp_deflate ; do
-   /sbin/insmod $module 2>/dev/null >/dev/null
-done
-               
-if test -d "/var/lock"; then
-  mkdir -p /var/lock || exit 1
-fi
-
-/usr/sbin/pppd pty "pptp x.x.x.x --loglevel 0 --nolaunchpppd" file /etc/ppp/options.pptp
-                   
-
diff --git a/openwrt/package/pptp/ipkg/etc/ppp/options.pptp b/openwrt/package/pptp/ipkg/etc/ppp/options.pptp
deleted file mode 100644 (file)
index 0eb1e87..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-lock 
-noauth 
-nobsdcomp 
-nodeflate
-mtu 1490
-mru 1490
-lcp-echo-failure 5
-lcp-echo-interval 120
-idle 0
-defaultroute
-name xxxx
-remotename xxxx
diff --git a/openwrt/package/pptp/ipkg/pptp.conffiles b/openwrt/package/pptp/ipkg/pptp.conffiles
new file mode 100644 (file)
index 0000000..136db31
--- /dev/null
@@ -0,0 +1 @@
+/etc/ppp/options.pptp
\ No newline at end of file
diff --git a/openwrt/package/pptp/ipkg/pptp.control b/openwrt/package/pptp/ipkg/pptp.control
new file mode 100644 (file)
index 0000000..67dbd26
--- /dev/null
@@ -0,0 +1,7 @@
+Package: pptp
+Priority: optional
+Section: net
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: a Point-to-Point Tunneling Protocol (PPTP) client
+Depends: ppp, kmod-gre
diff --git a/openwrt/package/pptp/pptp.control b/openwrt/package/pptp/pptp.control
deleted file mode 100644 (file)
index 67dbd26..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: pptp
-Priority: optional
-Section: net
-Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
-Source: buildroot internal
-Description: a Point-to-Point Tunneling Protocol (PPTP) client
-Depends: ppp, kmod-gre