[ar71xx] add dummy code for the TRENDnet TEW-632BRP board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 6 Dec 2008 18:10:57 +0000 (18:10 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 6 Dec 2008 18:10:57 +0000 (18:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13531 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h

index d6e3114..f15de1d 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
+CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
index 676fc24..86abe4a 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
+CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
index 3b11057..7e9b75c 100644 (file)
@@ -27,6 +27,10 @@ config AR71XX_MACH_RB_4XX
        bool "MikroTik RouterBOARD 4xx series support"
        default y
 
+config AR71XX_MACH_TEW_632BRP
+       bool "TRENDnet TEW-632BRP support"
+       default y
+
 endmenu
 
 endif
index dc682c8..37a1ebf 100644 (file)
@@ -14,4 +14,5 @@ obj-$(CONFIG_AR71XX_MACH_AP83)                += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
+obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
new file mode 100644 (file)
index 0000000..96f856b
--- /dev/null
@@ -0,0 +1,19 @@
+/*
+ *  TrendNET TEW-632BRP board support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+
+static void __init tew_632brp_setup(void)
+{
+}
+
+MIPS_MACHINE(AR71XX_MACH_TEW_632BRP, "TRENDnet TEW-632BRP", tew_632brp_setup);
index c77d418..1b7b3a7 100644 (file)
@@ -49,6 +49,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "AP83",
                .mach_type      = AR71XX_MACH_AP83,
+       }, {
+               .name           = "TEW-632BRP",
+               .mach_type      = AR71XX_MACH_TEW_632BRP,
        }
 };
 
index c204721..42db7cc 100644 (file)
@@ -113,6 +113,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_RB_493     5       /* Mikrotik RouterBOARD 493/493AH */
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
+#define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
 
 /*
  * PLL block