package: other.mk: update configuration for ad799x
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Sep 2014 20:35:10 +0000 (20:35 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Sep 2014 20:35:10 +0000 (20:35 +0000)
The ad799x driver moved out of staging since kernel 3.16, so update filepath,
config elements and description.

Signed-off-by: Hartmut Knaack <knaack.h@gmx.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42524 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 2f6f774..199e457 100644 (file)
@@ -242,14 +242,18 @@ define KernelPackage/iio-ad799x
   KCONFIG:= \
        CONFIG_AD799X_RING_BUFFER=y \
        CONFIG_AD799X
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
+  FILES:=$(LINUX_DIR)/drivers/iio/adc/ad799x.ko
+else
   FILES:=$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko
+endif
   AUTOLOAD:=$(call AutoLoad,56,ad799x)
 endef
 
 define KernelPackage/iio-ad799x/description
  support for Analog Devices:
  ad7991, ad7995, ad7999, ad7992, ad7993, ad7994, ad7997, ad7998
- i2c analog to digital converters (ADC). WARNING! This driver is still staging!
+ i2c analog to digital converters (ADC).
 endef
 
 $(eval $(call KernelPackage,iio-ad799x))