ar71xx: fix initramfs image generation for Cameo933x profiles
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Sep 2013 07:42:03 +0000 (07:42 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Sep 2013 07:42:03 +0000 (07:42 +0000)
Initramfs images are not generated for profiles which
are using the squashfs-only template. Add the missing
'Image/Build/Template/squashfs-only/initramfs' to fix
that.

Also, 'Image/Build/Cameo933x/initramfs' uses wrong
parameters for 'MkuImageLzma/initramfs' due to a
misplaced commma. Remove that to fix the generated
initramfs images.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37871 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index b755a9d..e786790 100644 (file)
@@ -386,7 +386,7 @@ define Image/Build/Cameo933x
 endef
 
 define Image/Build/Cameo933x/initramfs
-       $(call MkuImageLzma/initramfs,$(2),$(3),$(cameo933x_mtdlayout))
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo933x_mtdlayout))
 endef
 
 define Image/Build/Cameo933x_8M
@@ -816,6 +816,10 @@ define Image/Build/Template/squashfs-only/squashfs
        $(call Image/Build/$(1),squashfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef
 
+define Image/Build/Template/squashfs-only/initramfs
+       $(call Image/Build/$(1)/initramfs,initramfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
+endef
+
 define Image/Build/Template/64k/loader
        $(call Image/Build/$(1)/loader,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef