kernel: Add dummy sound driver
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Dec 2015 15:05:53 +0000 (15:05 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Dec 2015 15:05:53 +0000 (15:05 +0000)
Useful when using sound players that can send to icecast, etc. without any sound device attached.

Signed-off-by: Ted Hess <thess@kitschensync.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47852 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/sound.mk

index 603bb70..d09cf21 100644 (file)
@@ -273,3 +273,19 @@ define KernelPackage/pcspkr/description
 endef
 
 $(eval $(call KernelPackage,pcspkr))
+
+define KernelPackage/sound-dummy
+  $(call AddDepends/sound)
+  TITLE:=Null sound output driver (sink)
+  KCONFIG:= \
+       CONFIG_SND_DUMMY
+  FILES:= \
+       $(LINUX_DIR)/sound/drivers/snd-dummy.ko
+  AUTOLOAD:=$(call AutoLoad,32,snd-dummy)
+endef
+
+define KernelPackage/sound_dummy/description
+ Dummy sound device for Alsa when no hardware present
+endef
+
+$(eval $(call KernelPackage,sound-dummy))