[packages/kernel] Make mv_cesa crypto module available on Orion as well.
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Oct 2010 21:33:07 +0000 (21:33 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Oct 2010 21:33:07 +0000 (21:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23229 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/crypto.mk
target/linux/kirkwood/modules.mk [deleted file]

index 27cbf47..49c5684 100644 (file)
@@ -373,3 +373,14 @@ define KernelPackage/crypto-xts
 endef
 
 $(eval $(call KernelPackage,crypto-xts))
+
+define KernelPackage/crypto-mv_cesa
+   TITLE:=Marvell crypto engine
+   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+   SUBMENU:=Cryptographic API modules
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))
diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
deleted file mode 100644 (file)
index 736c82c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-
-define KernelPackage/crypto-mv_cesa
-   TITLE:=Marvell crypto engine
-   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
-   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
-   SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core @TARGET_kirkwood
-endef
-
-$(eval $(call KernelPackage,crypto-mv_cesa))