Remove preinit.arch, not used, compile NAPI support for R6040, change the profile...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jul 2007 15:05:16 +0000 (15:05 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jul 2007 15:05:16 +0000 (15:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8160 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc-2.6/config/default
target/linux/rdc-2.6/image/preinit.arch [deleted file]
target/linux/rdc-2.6/patches/002-r6040_ethernet.patch
target/linux/rdc-2.6/profiles/AR525W.mk [new file with mode: 0644]
target/linux/rdc-2.6/profiles/Ralink.mk [deleted file]

index 9ce729c..9ed3f86 100644 (file)
@@ -220,6 +220,7 @@ CONFIG_PHYSICAL_ALIGN=0x100000
 CONFIG_PHYSICAL_START=0x100000
 # CONFIG_PNPACPI is not set
 CONFIG_R6040=m
+CONFIG_R6040_NAPI=y
 # CONFIG_RELOCATABLE is not set
 # CONFIG_RPCSEC_GSS_KRB5 is not set
 # CONFIG_RTC is not set
diff --git a/target/linux/rdc-2.6/image/preinit.arch b/target/linux/rdc-2.6/image/preinit.arch
deleted file mode 100644 (file)
index 2e88efd..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-mount_root ${FAILSAFE:+failsafe}
-exec /bin/busybox init
index 333ec36..a403b0a 100644 (file)
@@ -1,7 +1,7 @@
 diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
 --- linux-2.6.17/drivers/net/Kconfig   2006-06-18 03:49:35.000000000 +0200
 +++ linux-2.6.17.new/drivers/net/Kconfig       2006-09-25 13:14:27.000000000 +0200
-@@ -1358,6 +1358,19 @@
+@@ -1358,6 +1358,23 @@
          <file:Documentation/networking/net-modules.txt>.  The module will be
          called apricot.
  
@@ -18,6 +18,10 @@ diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
 +          <file:Documentation/networking/net-modules.txt>.  The module will be
 +          called r6040.
 +
++
++config R6040_NAPI
++      bool "NAPI support for R6040"
++      default y
  config B44
        tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
        depends on NET_PCI && PCI && EXPERIMENTAL
diff --git a/target/linux/rdc-2.6/profiles/AR525W.mk b/target/linux/rdc-2.6/profiles/AR525W.mk
new file mode 100644 (file)
index 0000000..847607e
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ar525w
+  NAME:=AirLink101 AR525W
+  PACKAGES:=kmod-rt61 kmod-r6040
+endef
+$(eval $(call Profile,ar525w))
+
diff --git a/target/linux/rdc-2.6/profiles/Ralink.mk b/target/linux/rdc-2.6/profiles/Ralink.mk
deleted file mode 100644 (file)
index 847607e..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/ar525w
-  NAME:=AirLink101 AR525W
-  PACKAGES:=kmod-rt61 kmod-r6040
-endef
-$(eval $(call Profile,ar525w))
-