Add ndisc package, in its own menu to avoid breaking sort order
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 May 2005 01:51:58 +0000 (01:51 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 May 2005 01:51:58 +0000 (01:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1041 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/ndisc/Config.in [new file with mode: 0644]
openwrt/package/ndisc/Makefile [new file with mode: 0644]
openwrt/package/ndisc/ipkg/ndisc6.control [new file with mode: 0644]
openwrt/package/ndisc/ipkg/rdisc6.control [new file with mode: 0644]

index 705d7bc..5f42885 100644 (file)
@@ -40,6 +40,7 @@ source "package/kismet/Config.in"
 source "package/l2tpd/Config.in"
 source "package/lighttpd/Config.in"
 source "package/maradns/Config.in"
+source "package/ndisc/Config.in"
 source "package/net-snmp/Config.in"
 source "package/nfs-server/Config.in"
 source "package/nmap/Config.in"
index d595cd7..451fdd0 100644 (file)
@@ -52,6 +52,7 @@ package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_PACKAGE_MONIT) += monit
 package-$(BR2_PACKAGE_MYSQL) += mysql
 package-$(BR2_PACKAGE_NCURSES) += ncurses
+package-$(BR2_PACKAGE_NDISC) += ndisc
 package-$(BR2_PACKAGE_NET_SNMP) += net-snmp
 package-$(BR2_PACKAGE_NFS_SERVER) += nfs-server
 package-$(BR2_PACKAGE_NMAP) += nmap
diff --git a/openwrt/package/ndisc/Config.in b/openwrt/package/ndisc/Config.in
new file mode 100644 (file)
index 0000000..8759c32
--- /dev/null
@@ -0,0 +1,32 @@
+menu "ndisc - ICMPv6 discovery tools"
+
+config BR2_PACKAGE_NDISC
+       bool
+       default n
+       depends BR2_PACKAGE_NDISC6 || BR2_PACKAGE_RDISC6
+
+config BR2_PACKAGE_NDISC6
+       tristate "ndisc6 - ICMPv6 neighbour discovery tool"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_PACKAGE_NDISC
+       help
+         
+         ICMPv6 neighbour discovery tools
+         
+         http://people.via.ecp.fr/~rem/ndisc/
+         
+
+config BR2_PACKAGE_RDISC6
+       tristate "rdisc6 - ICMPv6 router discovery tool"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_PACKAGE_NDISC
+       help
+         
+         ICMPv6 router discovery tool
+         
+         http://people.via.ecp.fr/~rem/ndisc/
+         
+
+endmenu
diff --git a/openwrt/package/ndisc/Makefile b/openwrt/package/ndisc/Makefile
new file mode 100644 (file)
index 0000000..81d5c11
--- /dev/null
@@ -0,0 +1,41 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ndisc
+PKG_VERSION:=0.1.3
+PKG_RELEASE:=1
+PKG_MD5SUM:= c7a8acd8e3d1053265faa17f7edb75d6
+
+PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/ndisc/v0.1/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,NDISC6,ndisc6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,RDISC6,rdisc6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all
+       touch $@
+
+$(IPKG_NDISC6):
+       install -d -m0755 $(IDIR_NDISC6)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/ndisc6 $(IDIR_NDISC6)/usr/bin/
+       $(RSTRIP) $(IDIR_NDISC6)
+       $(IPKG_BUILD) $(IDIR_NDISC6) $(PACKAGE_DIR)
+
+$(IPKG_RDISC6):
+       install -d -m0755 $(IDIR_RDISC6)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/rdisc6 $(IDIR_RDISC6)/usr/bin/
+       $(RSTRIP) $(IDIR_RDISC6)
+       $(IPKG_BUILD) $(IDIR_RDISC6) $(PACKAGE_DIR)
diff --git a/openwrt/package/ndisc/ipkg/ndisc6.control b/openwrt/package/ndisc/ipkg/ndisc6.control
new file mode 100644 (file)
index 0000000..9135652
--- /dev/null
@@ -0,0 +1,8 @@
+Package: ndisc6
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
+Description: ICMPv6 Neighbour Discovery tool
diff --git a/openwrt/package/ndisc/ipkg/rdisc6.control b/openwrt/package/ndisc/ipkg/rdisc6.control
new file mode 100644 (file)
index 0000000..05df117
--- /dev/null
@@ -0,0 +1,8 @@
+Package: rdisc6
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
+Description: ICMPv6 Router Discovery tool