convert cifsmount to new packaging style
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 May 2005 19:28:24 +0000 (19:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 May 2005 19:28:24 +0000 (19:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@848 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/cifsmount/Makefile
openwrt/package/cifsmount/cifsmount.control [deleted file]
openwrt/package/cifsmount/ipkg/cifsmount.control [new file with mode: 0644]

index bfd2c9b..81eac62 100644 (file)
@@ -7,26 +7,20 @@ PKG_VERSION:=1.5
 PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/cifsmount
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
 
-$(PKG_BUILD_DIR)/sbin/mount.cifs:
-       mkdir -p $(PKG_BUILD_DIR)/sbin
-       $(TARGET_CC) -o $@ mount.cifs.c
-       $(STRIP) $@
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/sbin/mount.cifs
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+$(eval $(call PKG_template,CIFSMOUNT,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list:
-       $(IPKG) install $(PKG_IPK)
+$(PKG_BUILD_DIR)/.prepared:
+       mkdir -p $@
 
-source:
-prepare:
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
+       $(STRIP) $(PKG_BUILD_DIR)/mount.cifs
+       touch $@
 
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(IPKG_CIFSMOUNT):
+       mkdir -p $(IDIR_CIFSMOUNT)/sbin
+       install -m 0755 $(PKG_BUILD_DIR)/mount.cifs $(IDIR_CIFSMOUNT)/sbin/mount.cifs
+       $(IPKG_BUILD) $(IDIR_CIFSMOUNT) $(PACKAGE_DIR)
diff --git a/openwrt/package/cifsmount/cifsmount.control b/openwrt/package/cifsmount/cifsmount.control
deleted file mode 100644 (file)
index 145bc77..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: cifsmount
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: mount.cifs helper application for mounting remote CIFS shares
diff --git a/openwrt/package/cifsmount/ipkg/cifsmount.control b/openwrt/package/cifsmount/ipkg/cifsmount.control
new file mode 100644 (file)
index 0000000..145bc77
--- /dev/null
@@ -0,0 +1,6 @@
+Package: cifsmount
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: mount.cifs helper application for mounting remote CIFS shares