iptables: install libext*.a into staging dir
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Jun 2013 14:02:24 +0000 (14:02 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Jun 2013 14:02:24 +0000 (14:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36867 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iptables/Makefile

index 55f3a38..03f692e 100644 (file)
@@ -375,6 +375,10 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libip*tc.pc $(1)/usr/lib/pkgconfig/
+
+       # XXX: needed by firewall3
+       $(INSTALL_DIR) $(1)/usr/lib/iptables
+       $(CP) $(PKG_BUILD_DIR)/extensions/libext*.a $(1)/usr/lib/iptables/
 endef
 
 define Package/iptables/install