imx6: enable FPU for hard float
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Feb 2014 22:41:39 +0000 (22:41 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Feb 2014 22:41:39 +0000 (22:41 +0000)
The OpenWrt build system uses MACHINE_FEATURES of fpu to set the HAS_FPU which
in turn sets the default of CONFIG_SOFT_FLOAT as well as uClibc configuration.
As the IMX6 SoC has both vfpv3 and NEON hardware support we want to add fpu
to the feature list.  This will default the IMX6 target to use -mfloat-abi=hard
which will the be most efficient use of floating point.

When switching to hard float, we also need to enable VFP support in the kernel.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39759 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/imx6/Makefile
target/linux/imx6/config-3.10
target/linux/imx6/config-3.13

index 9ae1a4b..cee5b45 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=imx6
 BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie rtc usb usbgadget squashfs targz ubifs
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
index 3e69d68..3f189b8 100644 (file)
@@ -245,7 +245,7 @@ CONFIG_MUTEX_SPIN_ON_OWNER=y
 # CONFIG_MXC_IRQ_PRIOR is not set
 CONFIG_MXS_DMA=y
 CONFIG_NEED_DMA_MAP_STATE=y
-# CONFIG_NET_DMA is not set
+CONFIG_NEON=y
 CONFIG_NLS=y
 CONFIG_NLS_CODEPAGE_437=y
 CONFIG_NO_HZ_COMMON=y
@@ -350,7 +350,8 @@ CONFIG_USB_SUPPORT=y
 CONFIG_USE_GENERIC_SMP_HELPERS=y
 CONFIG_USE_OF=y
 CONFIG_VECTORS_BASE=0xffff0000
-# CONFIG_VFP is not set
+CONFIG_VFP=y
+CONFIG_VFPv3=y
 CONFIG_VMSPLIT_2G=y
 # CONFIG_VMSPLIT_3G is not set
 # CONFIG_XEN is not set
index 2506a0a..fc78c55 100644 (file)
@@ -246,6 +246,7 @@ CONFIG_MUTEX_SPIN_ON_OWNER=y
 # CONFIG_MXC_IRQ_PRIOR is not set
 CONFIG_MXS_DMA=y
 CONFIG_NEED_DMA_MAP_STATE=y
+CONFIG_NEON=y
 CONFIG_NET_FLOW_LIMIT=y
 CONFIG_NET_RX_BUSY_POLL=y
 CONFIG_NLS=y
@@ -345,7 +346,8 @@ CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
 CONFIG_VECTORS_BASE=0xffff0000
-# CONFIG_VFP is not set
+CONFIG_VFP=y
+CONFIG_VFPv3=y
 CONFIG_VMSPLIT_2G=y
 # CONFIG_VMSPLIT_3G is not set
 # CONFIG_XEN is not set