make the iptables package robust to kernel config changes
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Mar 2007 11:59:42 +0000 (11:59 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Mar 2007 11:59:42 +0000 (11:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6447 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iptables/Makefile

index 1b6bfc0..f29aad3 100644 (file)
@@ -163,7 +163,11 @@ define Package/ip6tables
   TITLE:=IPv6 firewall administration tool
 endef
 
+$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+
 define Build/Configure
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               clean
 endef
 
 define Build/Compile