Install libuci and headers in staging_dir
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Apr 2008 21:48:43 +0000 (21:48 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Apr 2008 21:48:43 +0000 (21:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10732 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uci/Makefile

index 54d01c1..41430f7 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -73,6 +73,13 @@ define Package/uci-sh/install
        $(CP) ./files/uci-sh/* $(1)/
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+endef
+
 $(eval $(call BuildPackage,uci))
 $(eval $(call BuildPackage,libuci))
 $(eval $(call BuildPackage,uci-sh))