openssl: disable mips16, it makes the code slower
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 May 2013 00:18:27 +0000 (00:18 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 May 2013 00:18:27 +0000 (00:18 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36602 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/openssl/Makefile

index 049aad4..0091579 100644 (file)
@@ -111,7 +111,7 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS := $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS)) $(FPIC)
 
 define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,