mac80211: fix autoprobing of mt7601u driver
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Nov 2015 21:24:28 +0000 (21:24 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Nov 2015 21:24:28 +0000 (21:24 +0000)
Strigng passed to autoprobing script should match
module's name. Currently that string is missing trailing "u".

With that change mt7601u driver really gets autoloaded on
USB Wi-Fi dongle insertion:
------------------>8---------------
[    0.930000] hub 2-0:1.0: USB hub found
[    0.940000] hub 2-0:1.0: 1 port detected
[    1.150000] usb 1-1: new high-speed USB device number 2 using
ehci-platform
[    1.720000] init: - preinit -
Detected arc-sdp // Synopsys AXS101 Development Board
[    1.810000] random: mktemp urandom read with 3 bits of entropy
available
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug
level
[    4.940000] procd: - early -
[    5.540000] procd: - ubus -
[    6.550000] procd: - init -
Please press Enter to activate this console.
[    7.160000] Loading modules backported from Linux version
master-2015-10-26-0-g28c26cb
[    7.170000] Backport generated by backports.git
backports-20150903-4-g12cf266
[    7.200000] cfg80211: World regulatory domain updated:
[    7.230000] cfg80211:  DFS Master region: unset
[    7.230000] cfg80211:   (start_freq - end_freq @ bandwidth),
(max_antenna_gain, max_eirp), (dfs_cac_time)
[    7.250000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz),
(N/A, 2000 mBm), (N/A)
[    7.270000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz),
(N/A, 2000 mBm), (N/A)
[    7.270000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz),
(N/A, 2000 mBm), (N/A)
[    7.290000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz,
160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[    7.290000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz,
160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[    7.310000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz),
(N/A, 2000 mBm), (0 s)
[    7.310000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz),
(N/A, 2000 mBm), (N/A)
[    7.330000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz),
(N/A, 0 mBm), (N/A)
[    7.470000] usb 1-1: reset high-speed USB device number 2 using
ehci-platform
[    7.620000] mt7601u 1-1:1.0: ASIC revision: 76010001 MAC revision:
76010500
[    7.630000] mt7601u 1-1:1.0: Firmware Version: 0.1.00 Build: 7640
Build time: 201302052146____
[    8.040000] mt7601u 1-1:1.0: Warning: unsupported EEPROM version 0d
[    8.050000] mt7601u 1-1:1.0: EEPROM ver:0d fae:00
[    8.050000] mt7601u 1-1:1.0: EEPROM country region 01 (channels 1-13)
[    8.320000] usbcore: registered new interface driver mt7601u
------------------>8---------------

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Dirk Neukirchen <dirkneukirchen@web.de>
Cc: Felix Fietkau <nbd@openwrt.org>
Cc: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47556 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/mac80211/Makefile

index aab057e..4b4f774 100644 (file)
@@ -1163,7 +1163,7 @@ define KernelPackage/mt7601u
   TITLE:=MT7601U-based USB dongles Wireless Driver
   DEPENDS+= +kmod-mac80211 +@DRIVER_11N_SUPPORT @USB_SUPPORT +kmod-usb-core
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/mediatek/mt7601u/mt7601u.ko
-  AUTOLOAD:=$(call AutoProbe,mt7601)
+  AUTOLOAD:=$(call AutoProbe,mt7601u)
 endef