brcm63xx: fix image generation and broken patch
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Feb 2015 23:48:32 +0000 (23:48 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Feb 2015 23:48:32 +0000 (23:48 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44569 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.18/513-MIPS-BCM63XX-add-inventel-Livebox-support.patch

index 0e59ab5..dd16355 100755 (executable)
@@ -97,6 +97,7 @@ define Image/Build/ZYXCFEDTB
 endef
 
 define Image/Build/RedBootDTB
 endef
 
 define Image/Build/RedBootDTB
+       # Generate the image
        gzip -9 -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(3) $(KDIR)/vmlinux-$(3).bin.l7
        dd if=$(KDIR)/vmlinux-$(3).bin.l7 of=$(BIN_DIR)/openwrt-$(2)-vmlinux.lzma bs=65536 conv=sync
        gzip -9 -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(3) $(KDIR)/vmlinux-$(3).bin.l7
        dd if=$(KDIR)/vmlinux-$(3).bin.l7 of=$(BIN_DIR)/openwrt-$(2)-vmlinux.lzma bs=65536 conv=sync
@@ -104,6 +105,7 @@ define Image/Build/RedBootDTB
 endef
 
 define Image/Build/HCSDTB
 endef
 
 define Image/Build/HCSDTB
+       # Generate the image
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(4) \
                --rev_maj=$(5) --rev_min=$(6) --input_file=$(KDIR)/$(7) \
                --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(4) \
                --rev_maj=$(5) --rev_min=$(6) --input_file=$(KDIR)/$(7) \
                --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
@@ -336,6 +338,6 @@ $(eval $(call ImageDTB,CFEDTB,TDW8900GB,TD-W8900GB,td-w8900gb,96348GW-11,6348,--
 # USRobotics 9108
 $(eval $(call ImageDTB,CFEDTB,USR9108,USR9108,usr9108,96348GW-A,6348))
 # ZyXEL P870HW-51a v2
 # USRobotics 9108
 $(eval $(call ImageDTB,CFEDTB,USR9108,USR9108,usr9108,96348GW-A,6348))
 # ZyXEL P870HW-51a v2
-$(eval $(call ImageDTB,ZYXCFEDTB,P870HW_51a_v2,96368VVW,p870hw-51a-v2,6368,P870HW-51a_v2,--rsa-signature "ZyXEL" --signature "ZyXEL_0001"))
+$(eval $(call ImageDTB,ZYXCFEDTB,P870HW_51a_v2,P870HW-51a_v2,p870hw-51a-v2,96368VVW,6368,--rsa-signature "ZyXEL" --signature "ZyXEL_0001"))
 
 $(eval $(call BuildImage))
 
 $(eval $(call BuildImage))
index 8a6d856..3842f7b 100644 (file)
@@ -57,7 +57,7 @@ Subject: [PATCH] MIPS: BCM63XX: add inventel Livebox support
  #endif /* __BOARD_COMMON_H */
 --- /dev/null
 +++ b/arch/mips/bcm63xx/boards/board_livebox.c
  #endif /* __BOARD_COMMON_H */
 --- /dev/null
 +++ b/arch/mips/bcm63xx/boards/board_livebox.c
-@@ -0,0 +1,214 @@
+@@ -0,0 +1,164 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive