[ar71xx] create firmware image for the Ubiquiti LS-SR71 board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Mar 2009 13:25:49 +0000 (13:25 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Mar 2009 13:25:49 +0000 (13:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14874 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile
tools/firmware-utils/src/mkfwimage.c

index fabe8de..f182f79 100644 (file)
@@ -73,7 +73,7 @@ define Image/Build/UBNT
                -B $(4) -v $(5).ar7100.OpenWrt.$(REVISION) \
                -k $(KDIR)/vmlinux-$(2).bin.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(2)-$(1).bin
+               -o $(BIN_DIR)/openwrt-$(BOARD)-$(2)-$(1).bin
 endef
 
 define Image/Build/Planex
@@ -171,7 +171,11 @@ define Image/Build/Profile/A02RBW300N
 endef
 
 define Image/Build/Profile/UBNTRS
-       $(call Image/Build/Template/UBNT/$(1),rs,board=UBNT-RS,RS,RSx)
+       $(call Image/Build/Template/UBNT/$(1),ubnt-rs,board=UBNT-RS,RS,RSx)
+endef
+
+define Image/Build/Profile/UBNTLSSR71
+       $(call Image/Build/Template/UBNT/$(1),ubnt-ls-sr71,board=UBNT-LS-SR71,LS-SR71,LS-SR71)
 endef
 
 define Image/Build/Profile/MZKW04NU
@@ -190,6 +194,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TEW652BRP,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
        $(call Image/Build/Profile/UBNTRS,$(1))
+       $(call Image/Build/Profile/UBNTLSSR71,$(1))
        $(call Image/Build/Profile/WP543,$(1))
 endef
 
index 8e505d7..fc1c6ce 100644 (file)
@@ -57,6 +57,12 @@ fw_layout_t fw_layout_data[] = {
                .kern_entry     =       0x80060000,
                .firmware_max_length=   0x00640000,
        },
+       {
+               .name           =       "LS-SR71",
+               .kern_start     =       0xbf030000,
+               .kern_entry     =       0x80060000,
+               .firmware_max_length=   0x00640000,
+       },
        {       .name           =       "",
        },
 };