[package] 6to4: follow RFC 6598 and consider 100.61.0.0/10 a private range (#11323)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 23 Apr 2012 10:12:00 +0000 (10:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 23 Apr 2012 10:12:00 +0000 (10:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31444 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6to4/Makefile
package/6to4/files.old/6to4.sh
package/6to4/files/6to4.sh

index 4563964..fc36d0f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=7
+PKG_VERSION:=8
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index f7f48e5..2329e0b 100755 (executable)
@@ -24,6 +24,10 @@ test_6to4_rfc1918()
        [ $1 -eq  10 ] && return 0
        [ $1 -eq 192 ] && [ $2 -eq 168 ] && return 0
        [ $1 -eq 172 ] && [ $2 -ge  16 ] && [ $2 -le  31 ] && return 0
+
+       # RFC 6598
+       [ $1 -eq 100 ] && [ $2 -ge  64 ] && [ $2 -le 127 ] && return 0
+
        return 1
 }
 
index 6825385..5cbdce7 100755 (executable)
@@ -31,6 +31,10 @@ test_6to4_rfc1918()
        [ $1 -eq  10 ] && return 0
        [ $1 -eq 192 ] && [ $2 -eq 168 ] && return 0
        [ $1 -eq 172 ] && [ $2 -ge  16 ] && [ $2 -le  31 ] && return 0
+
+       # RFC 6598
+       [ $1 -eq 100 ] && [ $2 -ge  64 ] && [ $2 -le 127 ] && return 0
+
        return 1
 }
 
@@ -221,7 +225,7 @@ proto_6to4_teardown() {
 }
 
 proto_6to4_init_config() {
-       no_device=1             
+       no_device=1
        available=1
 
        proto_config_add_string "ipaddr"