add 6tunnel package (thanks to Florian Fainelli)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Oct 2005 16:32:57 +0000 (16:32 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Oct 2005 16:32:57 +0000 (16:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2144 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/6tunnel/Config.in [new file with mode: 0644]
openwrt/package/6tunnel/Makefile [new file with mode: 0644]
openwrt/package/6tunnel/ipkg/6tunnel.control [new file with mode: 0644]
openwrt/package/Config.in
openwrt/package/Makefile

diff --git a/openwrt/package/6tunnel/Config.in b/openwrt/package/6tunnel/Config.in
new file mode 100644 (file)
index 0000000..d5c0cdb
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_6TUNNEL
+       tristate "6tunnel - IPv4 / IPv6 tunnel proxy"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_KMOD_IPV6
+       help
+         6tunnel allows you to use services provided by IPv6 hosts with IPv4-only 
+         applications and vice-versa. It can bind to any of your IPv4 (default) 
+         or IPv6 addresses and forward all data to IPv4 or IPv6 (default) host.
+         
+         http://toxygen.net/6tunnel/
+         
+
diff --git a/openwrt/package/6tunnel/Makefile b/openwrt/package/6tunnel/Makefile
new file mode 100644 (file)
index 0000000..3d5ef34
--- /dev/null
@@ -0,0 +1,58 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=6tunnel
+PKG_VERSION:=0.11rc1
+PKG_RELEASE:=1
+PKG_MD5SUM:=b325fa9d238e32195fbb3fc3646b0d28
+
+PKG_SOURCE_URL:=http://toxygen.net/6tunnel/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-0.11
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,6TUNNEL,6tunnel,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ac_cv_path_STRIP=$(STRIP) \
+               ac_cv_func_vsnprintf=yes \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/sbin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               default
+       touch $@
+
+$(IPKG_6TUNNEL):
+       install -d -m0755 $(IDIR_6TUNNEL)/usr/sbin
+       cp -fpR $(PKG_BUILD_DIR)/6tunnel $(IDIR_6TUNNEL)/usr/sbin/
+       $(RSTRIP) $(IDIR_6TUNNEL)/
+       $(IPKG_BUILD) $(IDIR_6TUNNEL) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/6tunnel/ipkg/6tunnel.control b/openwrt/package/6tunnel/ipkg/6tunnel.control
new file mode 100644 (file)
index 0000000..17da172
--- /dev/null
@@ -0,0 +1,7 @@
+Package: 6tunnel
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Florian Fainelli <florian@alphacore.net>
+Source: buildroot internal
+Depends:
+Description: An IPv4/IPv6 tunnel proxy
index 941c144..13da907 100644 (file)
@@ -35,6 +35,7 @@ endmenu
 source "package/screen/Config.in"
 
 comment "Networking"
+source "package/6tunnel/Config.in"
 source "package/aiccu/Config.in"
 source "package/amwall/Config.in"
 source "package/arpd/Config.in"
index e061e2b..f46f13b 100644 (file)
@@ -3,6 +3,7 @@ include $(TOPDIR)/rules.mk
 
 package-:=tcp_wrappers
 package-y:=nvram
+package-$(BR2_PACKAGE_6TUNNEL) += 6tunnel
 package-$(BR2_PACKAGE_AICCU) += aiccu
 package-$(BR2_PACKAGE_AMWALL) += amwall
 package-$(BR2_PACKAGE_ARPD) += arpd