ppp: enable IPv6CP by default
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Aug 2014 10:18:20 +0000 (10:18 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Aug 2014 10:18:20 +0000 (10:18 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42158 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/ppp/Makefile
package/network/services/ppp/files/ppp.sh

index 4cee97a..724be30 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 8f4cdeb..f07b11f 100755 (executable)
@@ -26,7 +26,11 @@ ppp_generic_setup() {
        local config="$1"; shift
 
        json_get_vars ipv6 demand keepalive username password pppd_options pppname
-       [ "$ipv6" = 1 ] || ipv6=""
+       if [ "$ipv6" = 0 ]; then
+               ipv6=""
+       else
+               ipv6=1
+       fi
        if [ "${demand:-0}" -gt 0 ]; then
                demand="precompiled-active-filter /etc/ppp/filter demand idle $demand"
        else