include/package-ipkg.mk: fix copying provides list introduced in r32332
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jun 2012 18:09:54 +0000 (18:09 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jun 2012 18:09:54 +0000 (18:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32358 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 7ff3f6e..0ce2055 100644 (file)
@@ -144,7 +144,7 @@ ifeq ($(DUMP),)
                        fi; \
                done; \
        ) | sort -u > $(PKG_INFO_DIR)/$(1).provides
-       $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$pkg.provides; done)
+       $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
        $(CheckDependencies)
 
        $(RSTRIP) $$(IDIR_$(1))