[kernel] add crypto-pcompress
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Dec 2012 01:59:29 +0000 (01:59 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Dec 2012 01:59:29 +0000 (01:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34685 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/crypto.mk

index 383f9f3..d824295 100644 (file)
@@ -60,6 +60,17 @@ define KernelPackage/crypto-manager
 endef
 $(eval $(call KernelPackage,crypto-manager))
 
+define KernelPackage/crypto-pcompress
+  TITLE:=CryptoAPI Partial (de)compression operations
+  KCONFIG:= \
+       CONFIG_CRYPTO_PCOMP=y \
+       CONFIG_CRYPTO_PCOMP2
+  FILES:=$(LINUX_DIR)/crypto/pcompress.ko
+  AUTOLOAD:=$(call AutoLoad,09,pcompress)
+  $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-pcompress))
+
 define KernelPackage/crypto-user
   TITLE:=CryptoAPI userspace interface
   DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager