mac80211: build airo on x86 only
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Mar 2016 12:52:24 +0000 (12:52 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Mar 2016 12:52:24 +0000 (12:52 +0000)
airo requires ISA_DMA_API and
that symbol is only set on some ppc,malta,x86
x86 is probably only platform where that driver is used

fixes buildbot errors on ar71xx,lantiq ...:
airo.ko is missing

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49073 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/mac80211/Makefile

index 734b6fe..4ab3899 100644 (file)
@@ -142,7 +142,7 @@ endef
 define KernelPackage/airo
   $(call KernelPackage/mac80211/Default)
   TITLE:=Cisco Aironet driver
-  DEPENDS+=@PCI_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-cfg80211
+  DEPENDS+=@PCI_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-cfg80211 @TARGET_x86
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/cisco/airo.ko
   AUTOLOAD:=$(call AutoProbe,airo)
 endef