ar71xx: move some always-used led related functionality from kmod packages to the...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Apr 2014 10:44:52 +0000 (10:44 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Apr 2014 10:44:52 +0000 (10:44 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40413 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/Makefile
target/linux/ar71xx/config-3.10

index fe54a52..25c51c3 100644 (file)
@@ -18,8 +18,7 @@ LINUX_VERSION:=3.10.34
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))
index f4d1fd8..10817ea 100644 (file)
@@ -196,9 +196,7 @@ CONFIG_IRQ_CPU=y
 CONFIG_IRQ_DOMAIN=y
 CONFIG_IRQ_FORCED_THREADING=y
 CONFIG_IRQ_WORK=y
-# CONFIG_LEDS_TRIGGER_DEFAULT_ON is not set
-# CONFIG_LEDS_TRIGGER_NETDEV is not set
-# CONFIG_LEDS_TRIGGER_TIMER is not set
+CONFIG_LEDS_GPIO=y
 # CONFIG_LEDS_WNDR3700_USB is not set
 # CONFIG_M25PXX_USE_FAST_READ is not set
 CONFIG_MARVELL_PHY=y